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Creating Basic Hardware and Software for
the Virtex-5 Embedded Kit

This tutorial is an introduction to Embedded System development with the Virtex-5
Embedded Kit. In this tutorial you will design a custom embedded hardware system and
develop simple application software without any OS/RTOS. For details on developing
applications with Linux or other RTOSes, refer the Ecosystem Support document on the
Virtex-5 Embedded kit page — http://www.xilinx.com/vSembedded.

Objectives

After completing this tutorial, you will be able to:
1. Create an Embedded system with the PowerPC processor for the Virtex-5
Embedded Kit (ML507 board) using Base System Builder (BSB) wizard

2. Generate and Download the FPGA design bitstream on the board using Xilinx
Platform Studio (XPS)

3. Create a simple software application using Eclipse-based Platform Studio
Software Development Kit (SDK)
4. Debug the software application using the Eclipse IDE (SDK)

Requirements

Embedded Development HW/SW Kit — Virtex-5 FX70T PowerPC and
MicroBlaze Processor Edition

The Virtex-5 Embedded Kit includes all of the items listed below except the
HyperTerminal program needed for RS232 UART output.

Hardware Requirements
e ML507 (Virtex-5 FX70T) board
e Xijlinx Platform Cable USB
e RS232 cable

Software Requirements

e |SE Design Suite 10.1 (including EDK 10.1) with Service Pack 2

¢ HyperTerminal program connecting the PC and the FPGA board at 115,200
baud
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Step 1 — Create Custom Embedded System - Hardware

@ 1. Open Xilinx Platform Studio

2' Create anew pI'OjCCtI o XilinxPlalfnrmS(udiu : _@
» o Select “Base System Builder wizard” | T
and Cth OK [@ © Blank XP5 project
E @ U OTEEEEE
| Brawse for More Projects v/

Browse installed EDK. examples [projects) here

oK. H Cancel ][ Help

3. Select the design directory for new project:

@ ® C(Click the Browse button and browse to a location on your computer:
C:\Workshop\ppc440_basic\
e The file name should be: system
Click Save
¢ C(Click OK

Platform Studio Project

Mew project Save in: |§_‘) ppcd40_basic j rji v
Project file My Recent Documents
- = : =2 Desktop
|C:Mwork shop/ppcd40_basic/spstern smp | i () My Documents
ty Recent _é My Computer (XSJTRADESHOWT)

Advanced options [optional: F1 for help) Documents < Local Disk (C)

i i e == 1) Workshap

Set Project Peripheral Repositories 1 =
= E o
| | | Browse .. <z DVD/CD-RW Drive [D:)
Lectop S My Metwark Places
|5) Urusedlcons
ok l [ Cancel ]

Iy Documents

Iy Computer
[#SJTRADES...

@ File name: |syslem wrnp L] Save |
Save as lype: |F’Iatf0rm Studio Project [*.xmp) LI Cancel

4. Next the Wizard will give options on how to create the system:
e Select “I would like to create a new design”
¢ Click “Next”

5. Select the target development board:
@ e Select Board vendor:“Xilinx”
e Select Board name: “Virtex-5 ML507 Evaluation Platform”
e Click “Next”
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x Virtex-5 Embedded Kit Tutorial

« Base System Builder - Select Board

Select a target development board:

Select board

(%) | would like ta create a spstem for the fallawing development baard
Board vendor: | Hilins

Board name: | Vikex 5 MLE0OY Evaluation Platform

ACLLE = B i R ey = [ gy gy | L L L L L L R R

Board revision: |Yirtex 4 MLA05 Evaluation Plathorm
Yirkex-4 L4100 Ewaluation Platform
YWirkex B MLE0T Ewaluation Platform
Wendor's Websil Vitex 5 MLE0S Evaluation Platform
YWirkex B MLB0E Ewaluation Platform
Dawriload E"-.-"irtEe:-: b MLEOY Ewaluation Platfarm
) | would like Spartan-34 D5P 1 EEI!J.-'E-. Starter Board
Spartan-3E 1600E MicroBlaze Dev Board

.. | Spartan-3 Starker Board
Bl:lard dESC”phD Crorbam, b Chorbor K b

The ML507 board iz intended to showzase and demonstrate Virtes-b technology. The MLE0S
board utilizes #iling Vitex 5 XCEVEAOT-FF1136 device. The board includes Tri-Mode Ethernet
MAC/PHY, 256MEB DDRZ SDRAKM SODIMM memary, TMB ZBT SRAM, 32MEB of Commodity
Flazh, 8kb IC EEPROM. CPU Debug and CPU Trace connectars, Swstem ACE CF contraller
and 2 A5232 zenal ports.

£

Mate: Wizt the

6. Select the processor:

With the BSB wizard you can design either MicroBlaze or PowerPC-based systems.
For this tutorial, you are going to use the PowerPC 440 processor available in
Virtex-5 FXT FPGAs.
e Select “PowerPC”
@ ¢ C(Click “Next”

7. Configure the processor options:
You can modify options like Processor or Bus Frequency, FPU, etc. Make sure the
“FPGA_JTAG” option is enabled for Debug setting. You will need this for Software

debugging in the next section of this tutorial.

For now, leave the defaults as-is. You can modify the system later.
@ ¢ C(Click “Next”
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8. Configure the I/O interfaces of your embedded system. Here you can select the
right set of Peripherals you need for your target system:
e For “RS232Select the drop down for “Baudrate’ and choose “115200”
@ ¢ Enable the check box “Use Interrupt”
¢ C(Click “Next”

« Base System Builder - Configure 10 Interfaces (1 of 4)

The following external memaory and 10 devices were found on pour board:
Hilir Wirkex 5 MLBO7F Evaluation Platform Revizion &

Pleaze zelect the [0 devices which you would like to use;

|0 devices
| B5232 Uart_1
Peripheral: | #P5 UARTLITE bl |

udrate [bits _
econds): 115200 »|

2400 s
Drata bify; 4800
P arity: 3600

19200

38400

Iz jmberrupt E7E00

e R
Bl
460200 : e

Penpheral: _KF'_S_LI.-';‘-. 21600 vl ¥

B audrate [bitz

per seconds]; 3600 W

Data bitg; a |
Prarity: NOME  w|

[] Use interupt

v| LEDz_BBit

Peripheral: | #F5 GFIO _v'
[] Use interrupt

< Back ” Hest > l ’ Cancel
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9. Continue configuring the I/O interfaces: (page 2 of 4). Leave the default options

@ as-1s.

¢ Click “Next”

« Base System Builder - Configure 10 Interfaces (2 of 4)

The follawing external memaory and [0 devices were found on pour board:
Hiling Yirtex 5 MLAOT Evaluation Platform B evision &

Pleaze zelect the [0 devices which you would like to use:

|0 devices

w| LEDz Positi
3 Positiong Dt Sheet

Beripheral: | =S GFIO w
[] Use jintermupt

w| Push_Butt BRIt
e Data Sheet

Peripheral: | =P5 GRID v
[] Usze interrupt

w| DIF_Switches_SBit
ohd e Data Sheet

Peripheral: | %P5 GPIO v
[] Use jntermupt

[IC_EEPROM Data Sheet

Peripheral: | PS5 IIC >
[] Usze interrupt

SRAk
Penpheral: %P5 MCH EMC w

Data Sheet

< Back ” Hest > l ’ Cancel
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10. Continue configuring the I/O interfaces. (page 3 of 4) Unselect the PCI Express
Bridge and Ethernet MAC as you will not be using it in this tutorial. This will
make the design smaller and also save some time when you create the FPGA
netlist/bitstream for this tutorial:
@ e Unselect “PCle_Bridge”
¢ Unselect the “Ethernet MAC”

« Base System Builder - Configure 10 Interfaces (3 of 4)

The follawing external memaory and [0 devices were found on pour board:
Hiline Virkex 5 MLEOT Evaluation Platform B evizion &

Pleaze zelect the [0 devices which vou would like to use;

|0 devices

FLASH

[ Data Sheet
PCle_Brid

[l =-Frege Data Sheet
Ethermet_kAaC

O =l Data Sheet

[ ot

Hard_Ethernet_MALC

AL el Data Sheet

< Back ” Hest » l ’ Cancel

Virtex-5 Embedded Kit Tutorial www.xilinx.com 6 Navanee S



Virtex-5 Embedded Kit Tutorial

®

®

®

11. Continue configuring the I/O interfaces (page 4 of 4). Unselect the SystemACE
peripheral as you will not be using it in this tutorial. This will make the design
smaller and also save some time when you create the FPGA netlist/bitstream for

this tutorial:

¢ Unselect SysACE_CompactFlash
¢ C(Click “Next”

« Base System Builder - Configure 10 Interfaces (4 of 4)

The follawing external memaory and [0 devices were found on pour board:
Hiling Yirtex 5 MLAOT Evaluation Platform B evision &

Pleaze zelect the |0 devices which you would like to use:

|0 devices

DDRZ_SDRAM

Beripheral: | PPC440MC DDR2 W

[] SwedCE_CompactFlash

12. Add some internal on-chip peripherals:

¢ C(Click “Add Peripheral”
e Select “XPS Timer”
¢ C(Click “Ok”

Data Sheet

Peripheras

sps_bram_i_crili_1
Periphersl: xPS BRAM IF CNTLR
Memary size:

eeeee

8KE v

PS BRAM IF CHTLR
%P5 TIMEBASE WDT
ancel

PS TIMER

13. Customize the Timer by enabling Interrupts:

¢ C(Click “Use Interrupt” for the timer
peripheral
e C(Click “Ok”

#ps_timer_1

Peripheral: %P5 TIMER

Counter bit width: 32 w
Timer mode
(&) Iwo timers are present

() One timer is present
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14. Next the wizard will help you create some sample programs that will do some
diagnostics on your custom embedded system.

You can leave the defaults and modify the software later:

¢ Click “Next”
¢ Click “Next”
¢ Click “Next”

15. Now you have finished creating a basic system. The wizard will let you review
your selections and generate the system:

o (Click “Generate”
e (Click “Finish”

Base System Builder,

Base System Builder, - System Created

Below iz a summaiy of the system vou have created. Pleaze review the information below, [f it is
corect, hit <Generater to enter the information into the =PS data base and generate the system files.
Othenmize return ko the previous page to make conmections.

Processor pped40_0
Proceszor clock frequency: 125.00 MHz
Bus clock frequency: 125.00 MHz
On Chip Mermary : 8KEB
Total Off Chip Memor: 1 MB
-GRAM = 1MB

The address maps below have been automatically assigned. You can modify them using the
editing features of XPS.

PLB Bus : PLB_¥46 Inst. name: plb_v46_0 Attached Components:

Core Name Instance Name Base Addr High Addr
wps_bran_if_cntl wps_brarn_if_cntlr_1 0«FFFFEDOD 0«FFFFFFFF
#ps_uartlite R5232_Uart_1 0x84000000 0x8400FFFF
#ps_uartlite R5232_Uar_2 084020000 0:B402FFFF
¥ps_gpio LEDs_8Bit 0x81400000 081 40FFFF
#ps_gpio LEDs_Positions 081420000 0x8142FFFF
Hps_gpio Push_Buttons_BBit 051440000 0:5144FFFF
%ps_gpio DIP_Switches_8Bit 0=51460000 0=5146FFFF
®ps_iic IIC_EEFROM 0x81600000 0xB160FFFF
#ps_mch_emc SRaM 0xFFE 00000 OFFEFFFFF
#ps_timer #ps_timer_1 0:83C00000 0:83COFFFF
®ps_intc wps_intc_0 081800000 0x8180FFFF

PPC440MC Bus : ppc440_0_PPC440MC Attached Components:

Core Name Instance Name Base Addr High Addr
ppcd40me_ddr2 DORZ_SDRAM 000000000 i
< Back I [ Generate I [ Cancel

l

The Bage System Builder has successfully generated your
embedded system!

Click. the Finish button to retun to XPS to compile your
hardware system and software
application,

i C:¥workshop\pped40_basichsystem.mhs ~
C:¥workshop\pped40_basichdatahsystem. ucf

C:¥workshop\pped40_basichetchlast_runtime.opt

C:¥workshop\pped40_basichetctdownload cmd

C:¥workshop\pped40_basichsystem mes
C:¥workshop\pped40_basichTestdpp_MemaonhsrchTestdpp_Memary.c
C:¥workshop\pped40_basichTestdpp_MemansrchT estdpp_Memary_LinkSerld
C:¥workshop\pped40_basichTestdpp_PeripheralsrchTestdpp_Peripheral ¢
C:¥workshop\pped40_basichTestdpp_Peripheralsrchsintc_tapp_example.c
C:¥workshop\pped40_basichTestdpp_Peripherahsrchinte_header b ~

Save settings file:

C:\wWorkshophppod40_basichsystem.bsb

The gettings file contains all the uzer's selections and inputs in the wizard session. It can be
lnaded in a future wizard session

< Back ] [ Finish I [ Cancel

16. If the following optional dialog appears, you can leave the defaults as-is.

o [Leave the default “Start
using Platform Studio”
o  (Click “OK”

[ Remember my selection and don't show this again ok, l [

What would vou like to do nest?

() Configure drivers and libraries [S oftware Platiom)
(©) Download the design to the board and test it
(O) Edit the test application generated by BSB

The Mext Step

Cancel
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Step 2 — Build and Download the Hardware system

1. From the Xilinx Platform Studio (XPS) IDE, create the FPGA bitstream and
download the hardware design onto the Spartan FPGA board as follows:

®

NOTE: This step will take almost 30 minutes. Do not close the window !

e Select the menu “Device Configuration-> Download Bitstream”

& Xilinx Platform Studio - C:MWorkshop/ppc440_basic/system.xmp - [System Assembly View1]

File Edit Wiew Project Hardware Software §eE EEWWGN Debug  Simulation Window  Help [=[&] %]
EO R EH D E R B G e B Updste sistream ARG i @i RNg i @X Brics REDONR
IE nformation Area Dognlcas Bshiesn M| & | Buslnteifsces | Ports | Addresses Epw EIF Filters

ioiect .. ipplicalions [itasig laf] Zrogram Flach termory . Narﬁe . Bus Ennnech‘nn IP Type IP Wersion 3
Flatform | WT&T, LN, [ ppeddd 0 ppeddd_vitesS  1.01.a
= Project Files Iy

tHS File: spstem.mhs L £ DOAZ SDR4M ppcddlme_ddi2  2.00.a

M55 File: system.mss 9 [E=RES el ] brarr

LICF File: data/spstem.ucf [ 9 E<

IMPACT Command File: ete/download. erd S [~ aps ttam & cnf T bram bram_block 1.00.a

Implementation Dptions File: etc/fast untime. opt e | B> fagore ol O jtagppe_cntlr 201k

Bitgen Options File: etc/bitgen.ut - <> ooc_ sys e 0 proc_sys_reset 200.a
= Project Options @ [

Drevice: wcBvia 7O 1361 9 E

Metlist Toplewel - E-

Implementation: XPS [fow] & [E=RE

HDL: YHDL 9 - L

Sim Model: BEHAVIORAL 9 e
=- Reference Files 9 E-P

Log Files - R

Synthesiz Repart Files & [EaRE 3

“ clock_gemerafor clock_generator  2.01.a
P SRAM uii bug solf O uhil_bus_split 1.00.a
[Platfarm Studio] | Swstem Assembly View | Block Diagram

P 1 VARNING:MDT - Use of repository located at C:4Xilinx}10.1\edk user repository} (equivalent of §XILINX EDE/../edk user repos
Lt apply to all the projectsWARNING:MDT - Use of repository located at C:VEilinxh10.1lvedk user repositoryh (equivalent of §)
to specify search paths that apply to all the projectsGenerating Block Diagram C:\Uorkshop\ppcqqo_basic\blkdiagram\sys\:el
Generated --- system.svg
Block diagrsm generated,

& Output “Waning || Emor

This will create the FPGA design files, synthesize the netlist and also place and route the
design creating the bitstream. The FPGA on the board will also be configured with this new
bitstream containing your custom embedded system.

Congratulations. Your Custom Hardware is now ready.
Next you will write and program some software.
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Step 3 — Develop Embedded software
1. From the Platform Studio IDE, launch Eclipse IDE for software development:

@ o Select the menu “Software->Launch Platform Studio SDK”

« Xilinx Platform Studio - C:\Workshop\MB_Workshop\mb_basicsystem.xmp. - [System Assembly View1] |:||E||§|

File Edit Yew Project Hardware Device Configuration Debug  Simulation  Window Help (=[] ]
i PR GBE@ el M iv0 20 i %
il SoFtware Platform Settings...
Fio . pesgniDeE sl Dt erfaces | Puarts " Addresses | [Ev BIF Filters]
i uba Generate Libraries and BSPs
Froiect | Applications = Bus Cannection IP Type IP Verzsion
Platform ﬂ &dd Software Application Project...  labze 0 microblaze 7108
= Proiect Fil A, Build Al User Applications Imb_«10 1.00.a
A .|Ie: aystem. mhs et Progra Size Irnb_w10 1.00.5
k55 File: syztem.msz i e | Il plb_wdf 1.02.a
UCF File: data/system.uck E SONGLATe INREL AENPT: oo Imb_bram_if_cntle - 2.10.a
iMPACT Command File: etc/dow % lean Librass i Imb_bram_if_cnte 2103
- Implernentation Options File: sto/f @ o BT E SOAAM mpmc 400.a
- - Bitgen Options File: etefhitgen.or : d 1EN brarm_block 1.00.5
E| Pm|ecl Options £ Clean Software b modtie rndrm 1.00.b
; - Device: xoded1 B00afgE7E-4 1 o— | - Swifches 85: #pE_gpio 1.00.5

2. In SDK, start creating a new software application using the Application Wizard:

@ e Select “Create a New SDK C Application Project”
¢ Click “Next”

AC++ - Xilinx Platform Studio SDK !Wnrkxhnp.fMB Workshop/mb_basic/system.xmp

File Edit Refactor Mavigate Search F Run  ‘Window Help

1M B0 5 6B ® R RO @G E G -0 B4 %

H| %CJC-H
@ Cic++ Projects 52 I = H & welcome 52

P | B &Y not available.

Welcome to Xilinx Platform
Studio SDK 10.1

[+l microblaze_0_sw_platform

« Application Wizard 7 Getting Started

Select a Wizard

Create a new C application project, and allow SDK to manage its Makefile. This is the typical starting
point unless you have already created your project,

‘Wizards:

Overview
Find out

ate 2 ) C Application Project
ljlmpurt #P5 Application Projects
ﬁlmport an Existing SDK Application Pyoject inta this Workspace

Tutorials

I Do not launch application Wizard at startup s

< Back I Mext = I Finish Cancel

Running execs generate for O5'es, Drivers and Libraries ...

LibGen Done.
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®

®

®

®

3. Provide a name to the new project
e Type “hello”
¢ Click “Next”

= New Project

Project Name: [ hello]

IV Create Sample File in Project

Pracessar: [micrablaze_0 (MICROBLAZE)

IV Use Defauit Location for Project (recommended)

Use the rest of the project defaults
¢ Click “Next”
¢ C(Click “Finish”

<gack

Cancel

wext> |[_gmsh

4. Now you have to edit the Linker Script of the program to make sure it will run

properly in hardware from DDR?2 external memory.

¢ Right Click on the “hello {ppc440_0_software_platform }”’

e Select “Generate Linker Script”

< C/C++ - main.c - Xilinx Platform Studio SDK - G:/Workshopsppc440_basic/system.anp.

Fle Edt Refactor Navigate Search Project ~XiincTools - Device Configuration Run Window Help

o= o E 8 @ BB g-68-E-6-$-0-Q%- &5

1// Welcome to Xilinx Platform Studio SDK !
2/

= S
1 ppe40_0._s

b his i3 an autowatically cresced source file to help you ge
b aad more files, navigate to File —> New -> File
bu may delete this file if you vant to use only other file

1 new

otk

Open i Hew Window
raing)

return 0;
= Copy

K Delete
Wove,
Rename

g Inpot.

et

& Refresh
Close Project

e

<} >
Rnas > Bl Console £2 | Praperties | AMD Cansale
Debug As »
Team b = EHp TUUHUES S ROULESS URFTIEL
Compare With » ¥ found hardware design.

Restore from Local Hitory R e B

Properties well to your hardware design.
|make: #wt [hello.elf] Error 2

In the Linker Script Generator dialog

o

= B || @ make Targets 52

=

- Try using the linker script gemeration tools to gemerate am ELF that

® =

% Wl ppct40_0_sw_platform

=0

e Select “DDR2_SDRAM?” for Assign all Code Section to:

e Select “DDR2_SDRAM?” for Assiin all Data Section to:
= Linker Script Generator E|

[ ihellofDebugihello. o
Code Sections

Assign all Code Sections to:

DDRZ_EDRAM_C_MEM_BASEADDRS -

| section | size (bytes) | Memary
0x000003EQ  DDRZ SDRAM. € MEM SASEADDR

Reference Views (reagponly)
Memaries:

text

L d Stacki
spplication project name: | hela TR
Section | #E (bytes) | Memory [
ELF file used to populate section info: Hesy oxiooe DORZ_SDRAM. C_MEM_ GASEAGOR
Do DRI SDRAM C_MEM_ BASEARDR

| Address

Memory

| size

Add Section | Delete Section

ps_bram_if _cntr_t
Data Sections

DDR2_SDRAM_C_MEM_BASEADDR. =

fssign all Data Sections to:

Baot and Vectar Sections:

DDRZ#ADRAM_C_MEM_BASEADDR 0x00000000 262144k
_C_MEMO_BASEADDR. OxFFEQDOO0  1024K

OxFFFFEDDD. 8K

: % Lo conan e eceico oo [ o [y \
g IAITINITLE ” bootd  OxFFFFFFO0 xps_bram_f_entk_1
sota oxonononon pokEEbEn Lot L . oot OsFFFEFFEC xps_bram if_cnth 1
sbssz  0x00000000  DORZ SDRAMLC_MEW EASEADDR T
data  OxOOODOUFS  DORZ SIRAMTC_MEMW EASEADDR
fixup  OXODOD0DOD  (DRZ SDRAA C_MEM SASEACDR
sdata  0x00000008  DORZ SORAM C_MEW SASEADDR
shss 0x0000000  DORZ_SDRAT.C_MEW EASEADIR Output Linker Sarpts
b5 0x000000IC  DORZ SORANT CMEW BASEADDR

[ €:jwiorkshopippc440_basic/SDK_pri hello.id

o

Generate Cancel
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5. In the Editor view, edit the default program “main.c” and save it:
@ ¢ Insert the following line after main() {
print (“Hello World”);

NOTE: It is print() and not printf().

@ o Select the menu “File-> Save”

= CIC++ - main.c - Xilinx Platform Studio SDK - C:/Workshop/MB_Workshop/mb_basic/system.xmp FLHEIE‘
7128 Edit Refactor Mavigate Search Project - kiink Tools - Device Configuration  Run ‘Window  Help
New seeshieen b (B we B R G- - -0 @ -
Open File...
Close Cerl+F4 1] &l B e st =7
Close all Cerl+shift+Fa
r 1// Welcome to Xilinx Platform Studio SDK ! 132 }TQ‘ \\f e
ass @ main
] 5ave A5 3// This is an automatically created source file to help you ge
4// To add more files, navigate to File -» New -> File
5 5ave all CtrkShift+S 5// You way delete this file if you want to use only other file
Revert 674
.
gint main()
=X
) . ; 10 print ("Hello Worldin"):
Convert Line Delimiters Ta 11 return 0;
= 1z}
= Print.... Ctrl+pP
- 13
Switch Workspace. ., 14
g Import...
3 Expart..,
Properties AlE+Enter
1 main.c [hella]
Exit
< | >
Froblems = Console £2 | Properties [ERE T [5-—4d
C-Build [hello]
S QR LRLINLILNY 515 UL LLE FLLE e 3
mb-size hello.elf
text data hs= dec hex filename
1710 3zo 1064 3094 cl6 hello.elf
Build complete for project hello

Saving the program will also compile it and result in “hello.elf” as you see in the console
view.

Now you are ready to download and debug the program on the board.
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SETUP - Setting Up Hyperterminal
1. Before debugging the Hello world program, you have to open the RS-232 serial
communication with the board using the Hyperterminal console program and set

the Baud Rate to be 115200 baud.

¢ From your Windows Desktop, select Start->All Programs->Accessories-
>Communications->Hyperterminal

¢ In Hyperterminal, give a name “115200” the Serial Connection

¢ In Hyperterminal, select “Connect Using” and select the Serial port on
your PC (Usually it is Com1).

¢ In Hyperterminal, Port Settings tab, select Bits per second as 115200, Data
bits as 8, Parity as None, Stop Bits as 1 and Flow control as None. Then
Click “Ok”

The output of your Hello world program can be seen in this console.

g COM1 Properties el
[ | PartSettings |

Bits per second: | 115200 v |

Data bits: -.8 |

Barity: | Maore “

Stop bitsr |1 . |

Flow cantrot |ETEES |

BRestore Defaults
ak ] [ Cancel ] [ Apply ]
;Disconnected Auka detect Auko detect LM
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Step 4 — Debugging software program

1. From SDK, start debugging the program as follows:
@ e Select the Menu item ‘“Run->Debug As->Debug on Hardware”

= CIC++ - main.c - Xilinx Platform Studio SDK - C:/Workshop/MB_Workshop/mb_basic/system.xmp Elﬁlg‘
File Edit Refactor Mavigate Search Project Xilinx Tools  Device Configuration NENGN ‘window Help
Th-H ony I R & - % Run Last Launched Chr+F1L - | 4 | *o

*#, Debug Last Launched Fi1

= 8| [§ *main.c 22 Run History 3 = B || 5= outiine 52 | ™1 =

» o
1// Weloome to Xili Run As iﬂz L% ‘6\5 e -
zj: Rt @ main
3 This is an autg 1= to hel
Debug Histary Pl

4/¢ To add wore £il
5/¢ You may delete
G4 Debug...
7

2int maini)
El

10 print ("Hello Worldin"):
11 return 0;

123

13

14

Debug As > 133 1 Debug on re

S: # Debug on Simulator

G, External Tocls 4

xS *

Ep
L

[
N

Problems | B Console 52 Properties

C-Build [hella]
e e JECECINIITLN SLIZE UL ELF FLLE rwrwmwmwrmrwre =
mb-size hello.elf
tEXt data has dec hex filensmwe
is10 3Z0 1064 3294 cde hello.elf
Build complete for project hello 2
v

Thello

SDK will now change to the Debug Perspective. SDK will also connect to the FPGA
board via the USB cable, connect to the MicroBlaze processor and download the
program to memory.

Now you are ready to debug the program using the Eclipse Debug perspective.
2. In the Debug perspective, click on the resume button (looks like Play button):

e (lick the “Resume” button
NOTE: You can alternatively select “Run->Resume”
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x Virtex-5 Embedded Kit Tutorial

Debug - main.c - Xilinx Platform Studio SDK - C:/Workshop/MB_Workshop/mb_basic/system.xmp

File Edit Refactor MNavigate Search Project - ®ilinx Tools - Device Configuration Run  ‘Window  Help
F-rleglh @B 82 R | BB [$%-0-%- @5 [H-4-0C-
B #;f&iDehug %CJ’C++
35 Debug 52 I3 B i# 7 T O | 0= variables 2 |Breskpoints Modules Registers &
=37 hello_Hw [xiinx CIC+H+
= "#MD karget debug agen
—l-gf® Thread [0] {Suspende
= 1 main{) at ..\rmain.c!

p Debuager Process (6/1/08 9:1
p CriworkshopiME_workshopimb_|

6105 9:13 PM) {Suspended)

0x000001bG

)
iciSDK_projectsiheliolDebugihelo.elf {6/ 1708 2:1

< ¥
1// Welcome to Zilinx Platform Studidy SDE ! -~ @ main

244

34/ This i= an automatically created source file to help you get started.

4// To add more files, navigate to File -> New -»> File

5// ¥ou way delete this file if you want to use only other files for your project.

6/
7
Sint main()
=8
B 10 print ("Hello Worldin™):
11 return 0; @
< >
Bl console 52 | Tasks | Memory el B -F-70

hello_Hw [Xilinz: CiC++ ELF] CihwarkshopiME_Workshopimb_basicySDE_projectsihellotDebugthello. elf (6108 9:13 PM)

‘Wiritable Smart Insert o1

You should now see the output of the program on the Serial console
(Hyperterminal) as follows:

Hello Horld

Congratulations. Your Software application is now
running on your custom hardware platform.
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Additional Exercises

You can now use the Eclipse IDE to modify your program and debug it
further. Following are some other Software exercises you can do to
import the board diagnostic programs created by Platform Studio and
test the LEDs, Buttons and other peripherals on the board:

1. In the SDK IDE source code perspective,
a. Select Xilinx Tools->Launch Application Wizard
b. Import Test_App_Memory and Test_App_Peripheral
programs.
c. Compile and Run (or Debug) these programs

2. While debugging,
a. View Registers, Memory
b. Single Step through the program using Step, Next
c. Toggle between assembly and source views

Inside Xilinx SDK IDE, Refer Help->Help Contents for
documentation on additional SDK features.
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