UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 13633

4.2i CORE Generator - "Error: An internal error has occurred; to resolve this error please consult.../Error: Sim has a problem implementing the selected core..."

Description

Keywords: Forward Error, Correction, update, install, Reed Solomon, Encoder v2.0, Decoder v2.0, Interleaver, Deinterleaver, v1.1, Viterbi, Decoder, v1.0, rs_encoder_v2_0, rs_decoder_v2_0, sdi_v1_1, vterbi_v1_0, E_IP1, internal, sim, implementing

Urgency: Standard

General Description:
I am using a Forward Error Correction (FEC) core (or I am using the Xilinx System Generator v2.1) with the Xilinx 4.1i software. I am using the Reed Solomon Encoder or Decoder v2.0, Interleaver or Deinterleaver v1.1, or Viterbi Decoder v1.1. After updating my software to version 4.2i (4.1i Service Pack 4), my core does not generate (or does not work).

The following error messages are associated with this situation:

"Coregen.log - generate
Error: Internal error has occurred; to resolve this error please consult..."

"Error: Sim has a problem implementing the selected core.
Sim Generator implementation netlist will not be generated.
Sim Generator: failure of sim to implement customization parameters."

"Error: Did not generate impl. netlist edn."

"Error: The XSF symbol generation support file cannot be generated."

Solution

If you are continuing to use the versions of the above cores after installing the 4.2i software, you must download an updated zip file to enable the cores to work correctly. This file is available at:
http://www.xilinx.com/ipcenter/fec_index.htm

Alternatively, you may download the newer versions of the cores from this same URL.

(NOTE: System Generator v2.1 users that are updating to 4.2i must download an updated version of the zip file for the Reed Solomon Encoder/Decoder v2.0, Interleaver/Deinterleaver v1.1, or Viterbi Decoder v1.1.)

Please note the installation order below:

1. 4.1i
2. IP Update #1 (also known as E_IP1)
3. Reed Solomon V2

Equivalently:

1. 4.2i - includes IP Update #1
2. Reed Solomon V2 ("special" 4.2i version)

For IP Update #2:

1. 4.2i
2. IP Update #2 (also known as E_IP2)
3. Reed Solomon V3
AR# 13633
Date Created 01/17/2002
Last Updated 10/08/2003
Status Archive
Type General Article