We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 1389

Xsimmake, Workview Office: Using Workview Office 7.1.2 or 7.2 with XACTstep 6.0.1 (Xsimmake failed)


Keywords: Xsimmake, XACT, Workview Office, failed

Urgency : Standard

Problem Description:
Here is a list of problems and workarounds for using Workview Office
with XACT 6.0.1.

1. XSIMMAKE fails - VSM not found
2. XSIMMAKE fails - Invalid keywords
3. XSIMMAKE fails - license is about to expire
4. Install DS-391



Viewlogic changed the functionality of VSM.EXE with the Windows 95/NT
versions of Workview Office - it is now a Windows GUI executable.
The old DOS vsm that xsimmake expects to run is now called VSM_NGUI.EXE.

To account for this problem and others, a patched xsimmake.xfw has been made.
It is on the FTP site at http://www.xilinx.com/txpatches/pub/swhelp/viewlogic/wvosim.zip.
This is valide for Workview Office versions 7.2 and older.

For Workview Office versions 7.3 and newer, the patch is slightly different.
Use the patch at http://www.xilinx.com/txpatches/pub/swhelp/viewlogic/wvosim73.zip.

Simply replace the xsimmake.xfw file in XACT\DATA with the one in the
zip file.

This patch is only needed for the versions of Workview Office that run on
Windows 95/NT (any version except 7.1.2).


Invalid keywords in viewdraw.ini file, such as:

Invalid keyword 'WINDOW_BACKGROUND'

can cause the tools, such as XSIMMAKE, to fail. Replace the viewdraw.ini
file with one from the CD ROM in PROSER\STANDARD, and update the libraries
by resaving the project file. You can also simply comment out these lines
in the viewdraw.ini file.


Product ds391 needs to be installed to the Workview Office directory.
The default for the install program is to install to the C:\PROSER
directory. Set this to point the the WVOFFICE directory. Either install
the Viewlogic Standard System or DS-391. Do not install the VIewlogic
Standard Standalone system; this will install PROseries.


If the license file is set to expire in 30 days or less, the warning
issued in vsm will cause XSIMMAKE to fail. To solve this, update your
license file with Viewlogic.
AR# 1389
Date Created 10/18/1996
Last Updated 03/11/1999
Status Archive
Type General Article