UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 141

QuickSim: Unable to resolve expression symbol lca_technology, NULL model will be inserted

Description

Keywords: QuickSim, lca_technology, NULL model

Urgency: Standard

General Description:

In Mentor 8, an error similar to the following may appear when invoking
Quicksim:

// Error: Unable to resolve expression symbol lca_technology (from:
DDMS/EDDM/EDDM General 41)
// Error: Instance: '/BLANK1'
// Trouble accessing MODEL property on primitive instance.
// May be bad property evaluation. NULL model will be inserted.
(from: Analysis/Digital Simulation Utilities/Dsim 16)
// Error: Unable to resolve expression symbol lca_technology (from:
DDMS/EDDM/EDDM General 41)
// Error: Instance: '/BLANK2'
// Trouble accessing MODEL property on primitive instance.
// May be bad property evaluation. NULL model will be inserted.
(from: Analysis/Digital Simulation Utilities/Dsim 16)
// Error: Unable to resolve expression symbol lca_technology (from:
DDMS/EDDM/EDDM General 41)
// Error: Instance: '/BLANK3/UNKNOWN1'
// Trouble accessing MODEL property on primitive instance.
// May be bad property evaluation. NULL model will be inserted.
(from: Analysis/Digital Simulation Utilities/Dsim 16)

Solution

1

For XACT 5.x users:

This is caused by a non-existent or incorrectly written simulation
viewpoint for the design. The solution is to run PLD_DVE_Sim on the
design, specifying the correct part family, from either PLD Design Manager
or the command line. An XC4000 design, for example, would use:

pld_dve_sim blanking_design xc4000

If a default viewpoint already exists, you will need to FIRST delete that
viewpoint before you can run PLD_DVE_Sim. See (Xilinx Solution 766).

Note: If Timsim8 -o was used to create the simulation model, be sure to run
Timsim8 instead of PLD_DVE_Sim. This is because Timsim8 -o links timing
information into the viewpoint after it runs PLD_DVE_Sim.

2

For Xilinx M1 or later users:

This is caused by a non-existent or incorrectly written simulation
viewpoint for the design. The solution is to run PLD_DVE -S on the
design, specifying the correct part family, from either PLD Design Manager
or the command line. An XC4000E design, for example, would use:

pld_dve -s blanking_design xc4000e default

Since PLD_DVE in M1 annotates pre-existing viewpoints, there is no need
to first delete a pre-existing viewpoint.
AR# 141
Date Created 08/31/2007
Last Updated 10/01/2008
Status Archive
Type General Article