UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 15501

6.2i/6.1i/5.2i/5.1i SmartModels - How do I install the 5.1i SmartModels for PPC and MGT components?

Description

Keywords: GT, GT10, PPC405, PPC, SWIFT, Smart Model, Smart Models, PPC, MGT

Urgency: Standard

General Description:
How do I install the SmartModels that are included in the 5.1i software?

In 6.1i, the SmartModels are automatically installed and the environment variables are set during the installation. For 6.1i, please skip the information below and go to the solutions linked at the bottom of this Answer Record.

Solution

SmartModels are included in the 5.1i software release as a 'tar" file.

For PC:
Xilinx\smartmodel\nt\installed_nt.tar

For UNIX:
Xilinx/smartmodel/sol/installed_sol.tar

The following steps outline how to set up the models for use:

1. Unzip or untar each file in the following directories:

For PC:
Xilinx\smartmodel\nt\

For UNIX:
Xilinx/smartmodel/sol/

2. Set the following variables:

For PC:
LMC_HOME = C:\Xilinx\smartmodel\nt\installed_nt

For UNIX:
setenv LMC_HOME $XILINX/smartmodel/sol/installed_sol
setenv LMC_CONFIG $LMC_HOME/data/solaris.lmc

setenv LD_LIBRARY_PATH $LMC_HOME/lib/sun4Solaris.lib:$LD_LIBRARY_PATH

The use of SmartModels is unique for each simulator. Refer to the following Answer Records for additional information.

Setting up MTI for use with SmartModels (Xilinx Answer 14019)
Setting up VCS for use with SmartModels (Xilinx Answer 18852)
Setting up NC-VHDL for use with SmartModels (Xilinx Answer 18853)
Setting up NC-Verilog for use with SmartModels (Xilinx Answer 14597)
AR# 15501
Date Created 09/03/2007
Last Updated 11/18/2008
Status Archive
Type General Article