We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 15699

5.1isp1 COMPXLIB, ModelSim - "ERROR: Cannot open C:\Xilinx\smartmodel\sol\wrappers\..." (PC only)


Keywords: 5.1i, COMPXLIB, compile, library, error, failed, cannot, open, wrapper, SmartModel

Urgency: Standard

General Description:
When I use COMPXLIB in the 5.1i software with Service Pack 1, the SmartModels are not compiled. In the COMPXLIB log file, the following type of errors appear:

For Verilog:
"ERROR: cannot open C:\Xilinx_51i\smartmodel\sol\wrappers\mtiverilog\GT10_SWIFT.v"

"** Error: (vcom-7) Failed to open design unit file "C:\Xilinx_51i\smartmodel\sol\wrappers\mtivhdl\smartmodel_wrappers.vhd" in read mode.
No such file or directory."

This only occurs on PCs. A a bug in COMPXLIB causes it to look in the "sol" directory instead of the "nt" directory.



An alternate way to work around the problem is by compiling the SmartModels manually. This can be done by copying the command line that was run from the COMPXLIB log file and replacing "sol" with "nt".

Example command lines illustrating how to manually compile the SmartModels with ModelSim are shown below.

For Verilog:
vlog -work C:\mylibs\unisim_ver C:\Xilinx\smartmodel\nt\wrappers\mtiverilog\*.v
vlog -work C:\mylibs\simprim_ver C:\Xilinx\smartmodel\nt\wrappers\mtiverilog\*.v

vcom -work C:\mylibs\unisim C:\Xilinx\smartmodel\nt\wrappers\mtivhdl\smartmodel_wrappers.vhd
vcom -work C:\mylibs\simprim C:\Xilinx\smartmodel\nt\wrappers\mtivhdl\smartmodel_wrappers.vhd


This problem is fixed in the latest 5.1i Service Pack, available at:
The first service pack containing the fix is 5.1i Service Pack 2.
AR# 15699
Date Created 09/26/2002
Last Updated 08/12/2005
Status Archive
Type General Article