We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 16192

Schematic - How do I create a symbol for a source that has not yet been created (top-down design)?


How do I create a design using "top-down" design methodology with ECS?


You can create a design using "top-down" methodology with ECS as follows:

1. Create the symbol with the desired input and output pins.

2. Create the underlying schematic or HDL source represented by the symbol.

3. Associate the symbol with the source.

1. Create the symbol

In ECS, select Tools -> Symbol Wizard and follow the steps for creating a symbol. Alternatively, you can manually create a symbol by selecting File -> New; then, select the symbol and click OK.

2. Create the source

In Project Navigator, select Project -> New Source:

- Choose the desired source type (VHDL Module, COREGen IP, Schematic, Verilog Module, ABEL-HDL).

- For File Name, enter the name that the symbol was given.

- Keep the checkmark in the "Add to project" check box.

3. Associate the symbol with the source

Project Navigator controls the ECS "Push/Pop" function. If you push into a user macro symbol in ECS, Project Navigator will open a source with the same root name if it has been added to the project.

For example:

- Create a symbol named "myand.sym".

- In ECS, select File -> New to create a new schematic and save it as "myand.sch".

- Add "myand.sch" to the project.

If you then place the "myand" symbol into a schematic and push into it, the "myand" schematic will be created.

If you now remove "myand.sch" from the project and add a new file named "myand.vhd" to the project, when you push into the symbol, you will be brought into HDL Editor and "myand.vhd".

For a Bottom-Up design

1. Create the source file.

2. Add it to the project using Project -> Add Source.

3. Highlight that source file, then select Design Entity Utilities -> Create Schematic Symbol.

You can then add the new symbol to a schematic design.

AR# 16192
Date Created 09/03/2007
Last Updated 12/15/2012
Status Active
Type General Article