UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 17113

Project Navigator - How can I manage multiple project versions in ISE? - Revision control

Description

How can multiple versions or revisions of a design project be saved using the ISE design tools?

Solution

Revision Control in ISE 10 and earlier

  1. Using Snapshot, select Project -> Take Snapshot from the Project Navigator menu. A snapshot contains a copy of all files in the project directory.
    The reports and source files of a snapshot can be viewed at any time. To edit or run a process on a file in a Snapshot, the snapshot must be changed to the current or working design.
    This can be done by highlighting the snapshot in the Snapshot View window and selecting Project -> Make Snapshot Current.

  2. Using Archive, select Project -> Archive from the Project Navigator menu to archive an entire project into a single compressed file.

  3. In ISE 9.2i and ISE 10, use Project -> Source Control -> Export and Project -> Source Control -> Import to publish a project to a staging area and later retrieve it.

  4. In ISE 9.2i and ISE 10, use Project -> Generate Tcl Script... to create a project-specific Tcl script that can be used to recreate the project, including setting project and process properties, adding sources, and running processes to recreate the state of the project.

Revision Control in ISE 11 and later

In ISE 11.1, the recommended way to facilitate revision control in Project Navigator is with the File -> Copy Project and the File -> Project Browser functions.

Project -> Archive is also available from the Project Navigator menu to archive an entire project into a single compressed file.

AR# 17113
Date Created 04/22/2003
Last Updated 09/24/2015
Status Active
Type General Article
Tools
  • ISE