We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 17541

5.2i CompXLib - "NOTE:compxlib[cmd]:2 - 'MTI_PE' edition does not support SWIFT_MODELS"


Keywords: compile, SmartModel, smart, model, mti_pe, mti, pe, support, swift

Urgency: Standard

General Description:
When running compxlib, I receive the following message:
"NOTE:compxlib[cmd]:2 - 'MTI_PE' edition does not support SWIFT_MODELS"


CompXLib does not currently compile the SmartModel wrappers for ModelSim PE. When the 5.1i software was released, ModelSim PE did not support the SWIFT interface. After the 5.1i release, ModelSim PE 5.7 was released with SWIFT support. CompXLib will compile the wrappers for ModelSim PE in the ISE 6.1i release.

To work around this issue, select MTI_SE (i.e., compxlib -s mti_se ...) as the simulator in the COMPXLIB command line. In the 5.2i/5.1i release, the only difference between selecting MTI_SE or MTI_PE is that the SmartModels are not compiled when you select MTI_PE.
AR# 17541
Date Created 06/25/2003
Last Updated 08/12/2005
Status Archive
Type General Article