We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 18163

LogiCORE SPI-4.2 (POS-PHY L4) v6.0 - SimGenerator internal error occurred when generating the pl4 v6.0 with CORE Generator 6.1i


General Description: 

The installation of the SPI4.2 v6.0.x core seemed to work well, but during the attempt to generate the respective core in CORE Generator 6.1i, several error messages occurred--and no output files were generated. 


Error message: 

"Preparing to elaborate core... Elaborating the module... ERROR: An internal error has occurred. To resolve this error, please consult the Answers Database at http://support.xilinx.com ERROR: Sim has a problem implementing the selected core. Implementation netlist will not be generated. ERROR: SimGenerator: Failure of Sim to implement customization parameters core v2p50 ERROR: Did not generate EDIF implementation netlist (.EDN) file for core <v2p50>. ERROR: Errors encountered while generating v2p50 (SPI-4.2 6.0). No output files have been generated."


SPI-4.2 (PL4) v6.0x requires CORE Generator 5.2i and SP3. Your must first install: ISE 5.2i with Service Pack 3 and IP Update # 2 (also known as F_IP2). The SPI-4.2 v6.0.x core is not supported on any other versions of ISE software (ISE 4.2i, ISE 5.1i, or ISE 6.1i). 



Once SPI-4.2 v6.0.x core is generated, it is possible to run implementation using ISE 6.1i. 


Keep your ISE 5.2SP3 version to generate and use ISE 6.1i to implement. Please see (Xilinx Answer 18500) for known issues with this flow.

AR# 18163
Date Created 09/03/2007
Last Updated 05/16/2014
Status Archive
Type General Article