UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 18275

7.1i Schematic - Device family specific library symbols are not available in schematic editor after changing the target device

Description

Keywords: ECS, ISE, device, specific, symbol, libraries, Project Navigator, missing, available

A schematic will not have access to the correct device-specific library symbols under the following circumstances:

1. There is a hierarchy of schematics in the design.
2. The target device in the design is changed from one device family to another.
3. The schematic is not on the top level of the schematic hierarchy.
4. One pushes into the schematic from a higher-level schematic by using the "Push into Symbol" option in the Schematic Editor.

Device-specific symbols relating to the original target device will be available in the Schematic Editor, but the device-specific symbols associated with the new target device will not be available.

Solution

To work around this problem:

1. Open each unique lower-level schematic directly by selecting and double-clicking it in the "Sources in Project" window.
2. Edit each schematic, save, and close.
3. When you now push into each schematic instance, the correct device-specific libraries and symbols will be available for use.

You can open the ".sch" file in a text editor to verify that the device family has changed (or to manually change the device family). The third line of text should contain the device family.

Example:
VERSION 6
BEGIN SCHEMATIC
BEGIN ATTR DeviceFamilyName "virtex"

This problem has been fixed in ISE 8.1i.
AR# 18275
Date Created 10/21/2003
Last Updated 12/12/2006
Status Archive
Type General Article