UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 19036

LogiCORE SPI-4.2 (POS-PHY L4) Lite v2.0.1 - Release Notes (PL4 Customers Only)

Description

General Description: 

This Answer Record contains the Release Notes for SPI-4.2, also known as POS-PHY Level 4 (PL4) Lite version 2.0.1. The following information is included: 

 

- Software Requirements 

- Supported Device/Package Information 

- What's New in SPI-4.2 Lite v2.0.1 

- Known Issues

Solution

Software Requirements 

SPI-4.2 Lite v2.0.1 has been verified with: 

- ISE 6.1i with Service Pack 3 (Spartan-3 requires an additional Speeds File patch. Please see (Xilinx Answer 18557) for more information.) 

- ISE 6.2i 

 

Supported Devices 

SPI-4.2 Lite v2.0.1 can be implemented in following device families: 

- Virtex-II 

- Virtex-II Pro 

- Spartan-3 

(No device/package restrictions exist for the Lite core.) 

 

What's New in SPI-4.2 Lite v2.0.1 

1. SOP Spacing Violation:  

The Sink core will only look at SOPs that are followed by data words when determining if SOP spacing violation has occurred. Any preceding SOPs are ignored. 

 

2. DIP4 errors are ignored while the core is out of frame: 

If a DIP4 error is received with a payload control word when the core is out of frame, the v2.0 core asserts the SnkBusErr signal while indicating on the SnkBusErrStat bus that DIP4 error was observed on training pattern or idles. This behavior is removed in the v2.0.1 release, and the core will ignore DIP4 errors received while the core is out of frame.  

 

Known Issues  

When a Spartan-3 device is targeted using ISE6.1i with Service Pack 3, timing fails if the latest speeds file (v1.29) is not used. Please install the Spartan-3 speeds file patch mentioned in (Xilinx Answer 18557)

 

Please see (Xilinx Answer 12420) for other SPI-4.2 issues that may apply to the SPI-4.2 Lite core.

AR# 19036
Date Created 09/03/2007
Last Updated 05/16/2014
Status Archive
Type General Article