UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 19795

6.3/6.2 EDK - How to upgrade OPB_MDM v1.00b/v1.00c to v2.00a

Description

Keywords: OPB_MDM, XPS, MB, BSCAN

Urgency: Standard

General Description:
How do I upgrade OPB_MDM v1.00b/v1.00c to v2.00a?

Solution

The opb_mdm v1.00b/c debug module has been replaced by opb_mdm v2.00a. The new version includes important enhancements like fast-download and BSCAN User1 export. If your designs are currently using one of the old cores, Xilinx recommends that you upgrade to v2.00a. If you prefer to continue using the old version, you can do so by following the steps in (Xilinx Answer 19531).

To upgrade, please perform the following steps:

1. Please modify the version parameter in your MHS from:

PARAMETER HW_VER=1.00.b

or

PARAMETER HW_VER=1.00.c

to be:

PARAMETER HW_VER=2.00.a

2. If your instance does not specify the parameters: C_BASEADDR and
C_HIGHADDR, please add the following to your MHS instance:

PARAMETER C_BASEADDR = 0xffff8000
PARAMETER C_HIGHADDR = 0xffff80ff

3. Your upgrade is now complete.
AR# 19795
Date Created 08/10/2004
Last Updated 04/10/2007
Status Archive
Type General Article