We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 2161

4.2i Foundation Project Manager - How can a user-created macro from one project be used in another project?


Keywords: macro, Foundation, schematic, user symbol, library, manager, copy, attach

Urgency: Standard

General Description:
How can a user-created macro from one project be used in another project?


There are two ways to utilize a user-defined macro created within another project:

1. You can either copy the macro from the original project's working library to the working library of your current project, or;
2. You can add the original project's working library to your current project. (In this case, your current project will share the library with the original project.)

To copy a macro from one library to another:

1. Run Library Manager by selecting File -> Project libraries from the Project Manager toolbar, and selecting "Library Manager".
2. Double-click the source library name in the Library Manager window. The List Objects... window will open.
3. Select the desired macro name.
4. Select Object -> Copy from the Library Manager toolbar. The Copy Object window will open.
5. Select the library name in the Destination Library list box, and then click the Copy button.
6. Click Close in the List Objects... window and exit Library Manager.

NOTE: If you copy HDL macros, you must manually copy source files (either *.VHD or *.ABL) from the original project directory to the current project directory.

To add an existing project library to the current project:

1. In Project Manager, choose File -> Project Libraries... from Project Manager. The Libraries window will open.
2. In the Attached Libraries list box, find and select the library you wish to add.
3. Click the Add>> button.
4. Click "Close" to complete the operation. All components from the other project are now available in your current project.
AR# 2161
Date Created 05/09/1997
Last Updated 08/12/2003
Status Archive
Type General Article