We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 21720

LogiCORE SPI-4.2 (POS-PHY L4) Lite v2.1 - Is SPI4.2 Lite Core supported on Spartan-3E?


General Description: 

Is SPI4.2 Lite Core supported on Spartan-3E?


Yes, Spartan-3E is supported with SPI4.2 Lite Core v2.1. The netlists files provided initially to target Spartan-3, Virtex-II, Virtex-II Pro, Virtex -4 can be used for targeting Spartan-3E. The User Constraint File (UCF) file needed in order to target Spartan-3E is provided in Spartan-3E supplementary file from the SPI4.2 lounge. Please follow these steps: 


1. Go to following SPI4.2 lounge: 

This is a SPI4.2 Lounge area that will require a valid password to access. 


2. Download "spi4_2_lite_v2_1.zip". (You may skip this step if you already have the original Lite v2.1 files installed.) 


3. Download "spi4_2_lite_v2_1_sp3e.zip" and copy it to your temporary directory. 


4. Extract the zip file over initial v2.1 files. 


Now, you should now have "spartan3e" sub-directory created under constraints directory, and the implementation script to run the design example should accept "spartan3e "as a valid option for the architecture. Please refer to following documentation for more information: 






NOTE: The SPI-4.2 Lite Core is verified against ISE 6.3i Service Pack 3. However, when targeting Spartan-3E, you must use ISE7.1i with Service Pack 2 or later. When targeting other devices such as Virtex-II, Virtex-II Pro, Spartan-3, it is recommended to use ISE7.1i with Service Pack 2 or later. Please be aware of the Virtex-II timing issue mentioned in (Xilinx Answer 21606).

AR# 21720
Date Created 09/04/2007
Last Updated 05/19/2014
Status Archive
Type General Article