^

AR# 22648 10.1 iMPACT - Installing Xilinx cable drivers on Linux operating system/kernel version 2.6

Keywords: operation, windrvr6, windrvr.o, mismatch, compiled, cable, parallel, platform, USB, 9.2i, 9.1i

Before a design tool can communicate with any Xilinx cable (e.g., Platform Cable USB, Parallel Cable IV, etc.), Xilinx cable drivers must be recompiled for the host system's Linux kernel version and then installed. Otherwise, the cable will not connect and the design tool will generate one or more of the following error messages:

"Module windrvr6 is not loaded. Please reinstall the cable drivers. See Xilinx Answer Record 22648."

"Please update to WinDriver version 8.02 or later. See Xilinx Answer Record 22648."

"/lib/modules/misc/windrvr6.o: kernel-module version mismatch
/lib/modules/misc/windrvr6.o was compiled for kernel version xxxxxx, while this kernel is version xxxxxx"

"insmod: error inserting lib/modules/misc/windrvr6.o: -1 Invalid module format "

Please refer to the "USB Cable Installation Guide" (UG344) and the install_drivers.tar.gz archive, which can be located at:

http://www.xilinx.com/support/documentation/configuration_hardware.htm

**Check that the fxload application is installed on your Linux install before installing drivers.
AR# 22648
Date Created 09/04/2007
Last Updated 07/09/2009
Status Active
Type