We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 22648

iMPACT - Installing Xilinx cable drivers on Linux operating system/kernel version 2.6


Before a design tool can communicate with any Xilinx cable (For example, Platform Cable USB, Parallel Cable IV, etc.), Xilinx cable drivers must be recompiled for the host system's Linux kernel version and then installed. 

Otherwise, the cable will not connect and the design tool will generate one or more of the following error messages:

Module windrvr6 is not loaded. Please reinstall the cable drivers. See Xilinx Answer Record 22648.

Please update to WinDriver version 8.02 or later. See Xilinx Answer Record 22648.

/lib/modules/misc/windrvr6.o: kernel-module version mismatch
/lib/modules/misc/windrvr6.o was compiled for kernel version xxxxxx, while this kernel is version xxxxxx"

insmod: error inserting lib/modules/misc/windrvr6.o: -1 Invalid module format


Please refer to the "USB Cable Installation Guide" (UG344) which includes a link to the install_drivers.tar.gz archive:


**Check that the fxload application is installed on your Linux install before installing drivers.

Linked Answer Records

Associated Answer Records

Answer Number Answer Title Version Found Version Resolved
34104 Configuration Design Assistant N/A N/A
AR# 22648
Date Created 01/07/2006
Last Updated 10/05/2016
Status Active
Type General Article
Boards & Kits
  • Platform Cable USB
  • Xilinx Parallel Cable IV
  • Platform Cable USB-II