UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 23959

8.2i EDK RTOS - WindRiver VxWorks 5.4/5.5 does not support OPB_ETHERNET v1.04.a with the EMAC v1.01.a driver

Description

WindRiver VxWords 5.4/5.5 does not support OPB_ETHERNET v1.04.a with the EMAC v1.01.a driver. The following errors occur when compiling the project:

"C:\my_tmp\customer\case_649122_felix_vxworks_9_8_06\test82\ppc405_0\bsp_ppc405_0_emac_101a

\ppc405_0_drv_csp\xsrc\xemac_end_adapter.c:2712: `ETHER_CRC_LEN' undeclared (first use in this function)

C:\my_tmp\customer\case_649122_felix_vxworks_9_8_06\test82\ppc405_0\bsp_ppc405_0_emac_101a

\ppc405_0_drv_csp\xsrc\xemac_end_adapter.c:2712: (Each undeclared identifier is reported only once

C:\my_tmp\customer\case_649122_felix_vxworks_9_8_06\test82\ppc405_0\bsp_ppc405_0_emac_101a

\ppc405_0_drv_csp\xsrc\xemac_end_adapter.c:2712: for each function it appears in.)"

Solution

To utilize OPB_ETHERNET v1.04.a with VxWorks 5.4/5.5, the EMAC driver must be set to version 1.00.e.

OPB_ETHERNET v1.04.a and EMAC driver version 1.01.a are only supported by VxWorks 6.1.

AR# 23959
Date Created 09/04/2007
Last Updated 12/15/2012
Status Active
Type General Article