UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 23991

10.1 EDK - When using ChipScope in an EDK design, I find that EDK always uses the last ChipScope version installed

Description

When using ChipScope in an EDK design, I find that EDK always uses the latest ChipScope version installed.

Is there a way to work around this issue? For example, I want to use ChipScope 9.1i with EDK 9.1i even though I have ChipScope 9.2i installed.

Solution

You can modify the PATH environment variable so that the earlier ChipScope version is used:

setenv PATH <chipscope_install>/<ChipScopeVersion>/bin/lin ${PATH}

Another option on Windows is to modify the registry as follows:

NOTE: Proceed with caution.

1. Regedit.

2. Change the version in HKEY_LOCAL_MACHINE/Software/Xilinx/ChipScope/CURRENTVERSION to the version you want to use.

AR# 23991
Date Created 09/04/2007
Last Updated 12/15/2012
Status Active
Type General Article