UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 24746

9.1i EDK - Using a Cygwin version earlier than 1.5-17 can cause errors at runtime

Description

Keywords: make, bash, dos2unix, newline, return, character

Which version of Cygwin can I use with EDK?

Solution

Cygwin version 1.5-17 has been tested and is the supported version to use with EDK. The make and bash executables with newer versions of Cygwin will cause runtime errors with EDK. Older versions of Cygwin have not been tested with EDK.

To work around the problem, you can do one of the following:

- Use the command xbash -override inside a DOS prompt to use the EDK version of Cygwin if the Cygwin version is older than the EDK installed version of Cygwin. This command needs to be executed only once. To undo what xbash -override has done, run the command xbash -undo.

- If the newer Cygwin must be used, replace the newer "make.exe" and "bash.exe" with the same files from the EDK installation.

The following Answer Records are related to this issue:
(Xilinx Answer 24134)
(Xilinx Answer 23716)
(Xilinx Answer 24121)
AR# 24746
Date Created 02/15/2007
Last Updated 07/17/2007
Status Active
Type General Article