UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 29124

LogiCORE SPI-4.2 (POS-PHY L4) v8.4 - Migrating from v8.3 to v8.4 (Migration Guide)

Description

This Answer Record shows how to migrate the SPI-4.2 Core from v8.3 to v8.4, and describes the signal changes made to the core. Every attempt was made to keep the constraints, input, and output signals consistent between versions. This Answer Record covers the modifications required to upgrade from v8.3 to v8.4. 

 

The following sections are included: 

 

- Wrapper File Changes 

- UCF and NCF File Changes

Solution

Wrapper File Changes 

The v8.4 wrapper file replaces the v8.3 wrapper file. 

 

UCF File Changes 

The UCF file must be updated by replacing all SPI-4.2 constraints in the UCF file with the SPI-4.2 constraints provided in the v8.4 release (use the v8.4 UCF files instead of the v8.3 UCF files).

AR# 29124
Date Created 11/14/2007
Last Updated 05/22/2014
Status Archive
Type General Article