We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 29580

9.2i EDK - "ERROR:MDT - chipscope_icon_0 (chipscope_icon) - Error Running Chipscope Core"


I have an embedded design in which a ChipScope Core has been inserted. When I run the generate netlist command in XPS, I receive the following error message: 


ERROR:MDT - chipscope_icon_0 (chipscope_icon) - Error Running ChipScope Core 

Generator : 

Please check your setup to make sure that ChipScope is installed properly  

and is available in the $PATH. 

Error message : "couldn't execute 

"c:\Xilinx\ChipScope_Pro_9_2i\bin\nt\generate.exe": no such file or 



- Update the PATH environment variable to include the path to the ChipScope "generate.exe" executable path: 



Create a registry entry key called CURRENTVERSION in "HKEY_LOCAL_MACHINE\SOFTWARE\Xilinx\ChipScope" and set it to 9.2. 

- Open the registry 

- Open the folder HKEY_LOCAL_MACHINE\SOFTWARE\Xilinx\ChipScope 

- right click on the right side of the registry window and select New >String Value 

- Name the key CURRENTVERSION 

- Close the registry 

- Update the EDK ChipScope pcores to look for ChipScope 9.2 as the default version.

AR# 29580
Date Created 10/28/2007
Last Updated 05/20/2014
Status Archive
Type General Article
  • ChipScope Pro - 11.1
  • ChipScope Pro - 12.1
  • ChipScope Pro - 13.1
  • More
  • EDK - 11.1
  • EDK - 12.1
  • EDK - 13.1
  • Less