UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 30003

9.2i EDK, MPMC v3.00b - MPMC PLB PIM does not support more than 8 PLB masters

Description

MPMC PLB PIM does not support more than 8 PLB masters. How do I resolve this?

Solution

This is caused by the PLB*_MID_WIDTH RANGE being too small. To work around the issue, copy the MPMC pcore from the %Xilinx_EDK%\hw\XilinxProcessorIPLib\pcores directory to the project directory. 

 

Then modify the "data/mpmc_v2_1_0.mpd" MPD file to change all PLB_MID_WIDTH RANGES from 0:3 to 0:4. 

 

This is fixed starting with MPMC v4.00.a, to be released in EDK 10.1.

AR# 30003
Date Created 01/03/2008
Last Updated 05/22/2014
Status Archive
Type General Article