UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 30384

ISE - Conflict in /usr/lib64/kde3/plugins/styles/, Plugin uses incompatible Qt library

Description

Keywords: Qt3, Qt4, lin32, lin64

When running Xilinx tools on Linux, the following messages (or similar) may be seen on the console:

Conflict in /usr/lib64/kde3/plugins/styles/dotnet.so:
Plugin uses incompatible Qt library!
expected build key "i686 Linux lin full-config no-opengl", got "x86_64 Linux g++-3.* full-config".
Conflict in /usr/lib/kde3/plugins/styles/kthemestyle.so:
Plugin uses incompatible Qt library!
expected build key "i686 Linux lin full-config no-opengl", got "i686 Linux g++-3.* full-config".

Solution

The messages are seen when the Xilinx qt library does not recognize some themes on the machine. These messages can be safely ignored.
AR# 30384
Date Created 02/25/2008
Last Updated 02/25/2008
Status Active
Type General Article