We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 30667

10.1 ISE - Migrating an EDIF project from ISE 8.x to ISE 10.1 fails


I cannot open my ISE 8.x EDIF project with project Navigator 10.1.


This problem occurs when the EDIF source file has not been explicitly set to top-level.

To resolve this issue, follow these steps:

1. In your 8.x Project Navigator, open your design.

2. Right-click the EDIF source and select "Set as Top Module."

3. Close the project and open it in Project Navigator 10.1.

This problem has been fixed in the latest 10.1 Service Pack available at:

The first service pack containing the fix is 10.1 Service Pack 2.

AR# 30667
Date Created 04/03/2008
Last Updated 05/13/2010
Status Archive
Type General Article