We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 31704

Endpoint Block Plus Wrapper v1.10 and v1.10.1 for PCI Express - Importing a v1.8 XCO to v1.9 causes "Error:sim228 -An Invalid core configuration has been detected during Customization."


Known Issue: v1.10, v1.9

When importing a v1.8, v1.7.1 or v1.6.1 XCO file into CORE Generator for generation of a v1.9 or v1.10 core, I might receive the following error:

Customizing IP...
ERROR:sim - Expansion_Rom_Scale: Invalid value 'Kilobytes'.
ERROR:sim - Expansion_Rom_Size: Invalid value '4'.
ERROR:sim:228 - An invalid core configuration has been detected during Customization. Core parameters will be reset to their default values.


This is due to the change made to remove the Expansion ROM disable feature. See (Xilinx Answer 31572) under the General Information section and CR 473951 in the Resolved Issues section.

To fix this, open the XCO file in a text editor. Replace the lines:

CSET expansion_rom_bar=00000000
CSET expansion_rom_enabled=false


CSET expansion_rom_bar=FFF00001
CSET expansion_rom_enabled=true

Release History
04/13/2009- Updated for ISE 11.1 and core version v1.10.
09/17/2008 - Initial Release.
AR# 31704
Date Created 09/23/2008
Last Updated 12/15/2012
Status Active
Type General Article
  • Virtex-5 Integrated Endpoint Block