UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 34608

12.1 EDK - What do I need to do to migrate my software application from 11.x SDK to 12.1 SDK?

Description

What do I need to do to migrate my software application from 11.x SDK to 12.1 SDK?

Solution


SDK is based off of Eclipse. Eclipse has a concept of Workspaces that contains the settings of the project on which you are working. It is recommended that instead of trying to preserve all of the project settings from one Workspace version to another Workspace version, that you import only the projects fromSDK's 11.xWorkspace:
Create a New Hardware Platform for SDK
1. Open your EDKdesign in XPS 12.1.
2. Click through the version migration wizard.
3. Be aware of the new drivers that are available for 12.1. The 12.1 drivers are written for a hardware abstraction layer and the function calls have changed; refer to (Xilinx Answer 35400).
4. In XPS, select Project > Export Hardware Design to SDK.
5. Select the Export & Launch SDK button.

SDKcreatesa new workspace with the default directory SDK_Workspace_35.

Import Existing BSP

In SDK 12.1, software platforms are referred to as Board Support Packages (BSPs).
1. Click on File > Import.
2. Expand "General" and select Existing Projects into Workspace.
3. Navigate to the 11.x workspace and find your Software Platform / BSP from the previous project, and select OK.
4. Select the software platform project to be imported.
5. Enable the "Copy Projects into Workspace" option, and press Finish.
6. Right-click on the newly imported BSP and select Close Project.
7. Right-click on the BSP project again and select Open Project. These two steps work around an Eclipse bug.

To make sure that the BSP project has been updated properly, right-click on the BSP and click on "Board Support Package Settings". Make sure the dialog comes up properly. If it fails to come up, that implies that the BSP project has not been imported properly. In such a case, create a new BSP using SDK and manually update the BSP to reflect settings from 11.x.

Import Existing C Application Project
1. Click on File > Import.
2. Expand "General" and select Existing Projects into Workspace.
3. Navigate to the 11.x workspace and find your C application project from the 11.x project, and select OK.
4. Select the software project to be imported.
5. Enable the "Copy Projects into Workspace" option, and press Finish.
6. Let SDK migrate the build settings from the 3.0.0 format to the 4.0.0 format.

If you receive an error after importing your 11.x C application project, select Project > Clean after which the project automatically rebuilds and cleans out any inconsistent data files from the 11.x build to the 12.x project.

Linked Answer Records

Master Answer Records

Answer Number Answer Title Version Found Version Resolved
34609 12.x EDK - Master Answer Record List N/A N/A
AR# 34608
Date Created 04/26/2010
Last Updated 12/15/2012
Status Active
Type General Article
Tools
  • EDK - 12.1