UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 35533

12.1 EDK - "ERROR:HDLParsers:3014 - "../addr_reg_cntr_brst_flex.vhd" Line 163. Library unit plbv46_slave_v1_04_a is not available in library plbv46_pcie_v4_04_a_plbv46_slave_v1_04_a"

Description

After making my PLBv46 PCIe core local in the system assembly view, the implementation results in the following error:

"ERROR:HDLParsers:3317 - "C:/ml507_12/pcores/plbv46_pcie_v4_04_a_plbv46_slave_v1_04_a/hdl/vhdl/addr_reg_cntr_brst_flex.vhd" Line 162.
Library plbv46_slave_v1_04_a cannot be found.
ERROR:HDLParsers:3014 - "C:/ml507_12/pcores/plbv46_pcie_v4_04_a_plbv46_slave_v1_04_a/hdl/vhdl/addr_reg_cntr_brst_flex.vhd" Line 163.
Library unit plbv46_slave_v1_04_a is not available in library plbv46_pcie_v4_04_a_plbv46_slave_v1_04_a.
ERROR:EDK:546 - Aborting XST flow execution!
INFO:EDK:2246 - Refer to C:\ml507_12\synthesis\pcie_bridge_wrapper_xst.srp for details"

Solution

To work around this issue, copy the pcores and its dependent libraries manually to the local pcores folder.

The following libraries are used by the plbv46_pcie_v4_04_a:

block_plus_v1_13_a
plbv46_master_v1_04_a
plbv46_slave_v1_04_a
proc_common_v3_00_a
spartan6_pcie_v1_04_a
virtex6_pcie_v1_04_a

Alternatively, a local copy of plb_v46_slave_v1_04_a resolves the issue.

AR# 35533
Date Created 05/05/2010
Last Updated 05/05/2010
Status Active
Type Known Issues
Devices
  • Virtex-5 FXT
  • Virtex-5 LX
  • Virtex-5 LXT
  • Virtex-5 SXT
Tools
  • ISE Design Suite - 11.4
  • ISE Design Suite - 11.5
  • ISE Design Suite - 12.1
  • More
  • EDK - 11.5
  • EDK - 12.1
  • Less
IP
  • PLBv46 PCIe