We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 35834

11.x/12.x iMPACT - Advanced cable setup only finds one cable


When attempting to connect to multiple boards using the Advanced Cable Setup dialog in iMPACT, only he first board is recognized. After switching to a second cable in the Advanced Cable Setup, I cannot then select a new cable and board. iMPACT will keep detecting the cable I originally selected. How do I work around this issue?


This issue will occur if you change the cable used in the Advanced Cable Setup and then try to initialize chain in the Boundary Scan window. The cable will not be updated. To change cables, first select the cable required in the Advanced Cable Setup and then to detect the JTAG chain use Output > Cable Auto Connect, then initialize chain. This will update the cable to be used and select the correct cable and board. This issue will be resolved in iMPACT 12.3

Linked Answer Records

Master Answer Records

Answer Number Answer Title Version Found Version Resolved
35448 12.x iMPACT - Known Issues N/A N/A
AR# 35834
Date Created 05/27/2010
Last Updated 12/15/2012
Status Active
Type General Article
  • ISE Design Suite - 11.1
  • ISE Design Suite - 11.2
  • ISE Design Suite - 11.3
  • More
  • ISE Design Suite - 11.4
  • ISE Design Suite - 11.5
  • ISE Design Suite - 12.1
  • Less
Boards & Kits
  • Platform Cable USB
  • Platform Cable USB-II