UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 373

XACT 5.0 memory manager requirements for all products

Solution




These are the memory manager requirements for the Virgil software:

1) XACT 5.0, including all third party interface programs and Xabel:
None required. Works with any memory manager that provides XMS, VCPI,
or DPMI standards. The only memory managers we have tested are
Microsoft HIMEM and Quarterdeck QEMM386.

2) OrCAD 386+ v1.10 (the version we support):
Same as 1) above.

3) Workview 4.1.3a (the version we OEM):
None required. On the contrary to Viewlogic's app note and our
recommendation to use QEMM in the past, theoretically it should NOT
behave correctly under any memory manager.

4) Microsoft Windows 3.1:
Requires HIMEM, QEMM386, or any other memory manager that provides XMS.
The only memory managers we have tested are Microsoft HIMEM and
Quarterdeck QEMM386.

5) Microsoft disk cache program SMARTDRV:
Same as 4) above.

Extra considerations:

- Workview works OK most of the time, when used under EMM386. It has been
known to crash the PC if XACT 5.0 is run after doing certain operations
in Workview however.


AR# 373
Date Created 08/31/2007
Last Updated 10/29/1997
Status Archive
Type ??????