UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 42159

System Generator - Subsystem CE signals do not affect the simulation, subsystems are always enabled

Description

I am running a simulation of a System Generator design which contains subsystems which are using CE signals to control whether a subsystem should be enabled or not .

During simulation the CE signal appears to have no effect.

The Subsystem is always enabled.

Solution

This is a known issue with ISE Sysgen and there is no plan to modify this behavior as a workaround exists.

It was found that the "subsystem_#_cw.vhd" file produced by System Generator incorrectly sets the "sysce" signal to 1. 

To work around the issue, this file needs to be modified to connect the "sysce" signal to "ce" within the "subsystem_#_cw.vhd" file. 

This will allow the CE signal to control the subsystem as expected.


AR# 42159
Date Created 05/16/2011
Last Updated 09/02/2014
Status Active
Type General Article
Tools
  • System Generator for DSP - 13
  • System Generator for DSP - 13.1
  • System Generator for DSP - 13.2
  • More
  • System Generator for DSP - 13.3
  • System Generator for DSP - 14
  • System Generator for DSP - 14.1
  • System Generator for DSP - 14.2
  • System Generator for DSP - 14.3
  • System Generator for DSP - 14.4
  • System Generator for DSP - 14.5
  • System Generator for DSP - 14.6
  • System Generator for DSP - 14.7
  • Less