UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 45010

Does CompXlib support Riviera-PRO 2011.10.77?

Description

When running the CompXlib tool, the follow error message occurs:

ERROR:Compxlib - Compxlib does not support riviera version prior to 8.3. Parsing through the path setting on your system we have identified that you are using riviera '2011.10.77'.
Please contact Aldec to upgrade to a supported simulator version. If the path setting is incorrect, please ensure that you are pointing to the latest version and re-invoke compxlib.
The list of supported simulator versions are listed in the Simulation Chapter of the Synthesis and Simulation Design Guide on http://www.xilinx.com.

Solution

When running CompXlib, the tool checks for supported versions of the targeted simulation tool. 

During the 13.3 release timeframe a new version of the Riviera-PRO simulation tool was released, '2011.10.77'.

The CompXlib tool does not recognize this version of the tool as being supported, and requires a workaround to generate the simulation libraries for the tool.

This issue will be fixed in the upcoming version of ISE, 13.4. 

Until then please use one of the two following solutions:

  • Download the precompiled libraries from the Riviera-PRO download page on www.aldec.com -> Download -> Riviera-PRO.
    You will have to either log in or register.
     
  • Run CompXlib in batch mode with the -oem switch:

compxlib -s riviera -p <Riviera-PRO Install Dir>\bin -l all -arch all -lib all -w -dir <Destination Dir> -oem 
AR# 45010
Date Created 11/14/2011
Last Updated 01/28/2015
Status Active
Type General Article
Tools
  • ISE Design Suite