UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 5099

F1.5 Foundation - How to use the Xilinx Constraints Editor with Foundation F1.5

Description

Keywords: Constraints Editor, UCF, timespecs, constraints

Urgency: Standard

General Description:
How do I invoke the Xilinx Constraints Editor (Xilinx graphical constraint entry program) when using the Foundation F1.5 flow?

Solution

The Xilinx Constraints Editor is used after the Translate phase of the design flow. At the current time, the Constraints Editor is invokable
from the Foundation Program Group:
(Start -> Programs -> Xilinx Foundation Series -> Accessories -> Constraints Editor).

After you have entered your design in the Foundation environment, you must Translate it in the Flow Engine before using the
Constraints Editor. Follow these steps to perform this "Translation."

First, be sure that the design netlist is up-to-date before proceeding. If the design is a schematic, select Options -> Export Netlist from the
Schematic Editor to export an updated netlist. If the design is HDL, be sure that the design has been synthesized successfully.

1. From the Foundation Project Manager, select Project -> Create Version.
2. Highlight the newly created Version, and select Project -> Create Revision.
3. Right-click on the newly created Revision, and select Invoke Interactive Flow Engine.
4. Press the STEP button (the 2nd from the left) at the bottom of the Flow Engine to advance the flow through just the Translate phase.
5. Close the Flow Engine.
6. Invoke the Constraints Editor from the Windows Start menu:
Start -> Programs -> Xilinx Foundation Series -> Accessories -> Constraint Editor.
7. From within the Constraints Editor, select File -> New. Browse to the project directory, and select the UCF file.
8. Next, you will be prompted to select an NGD file. This is located in the XPROJ\<VER>\<REV> within the project directory.
9. The Constraints Editor should now be ready for use.
AR# 5099
Date Created 11/24/1998
Last Updated 03/07/2002
Status Archive
Type General Article