We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 52990

2013.x Vivado - Vivado IDE does not open when the install path includes unicode characters


I installed Vivado to a directory containing unicode (double byte; for example Korean, Chinese, Japanese) characters.

The install completed successfully but when I attempt to open Vivado I receive a message indicating that the Vivado.tcl file does not exist.  

The unicode characters appear to have been changed to question marks (??????????).

couldn't read file "C:/Xilinx/????????? for _P28xd/14.2.ISE_DS.PlanAhead\lib\scripts\rdi\products\Vivado.tcl": no such file or directory
INFO: [Common 17-206] Exiting Vivado...


This issue arises when the system's format (Region and Language - Control Panel) is not set correctly and the Vivado installation path contains Chinese or Japanese characters.

For more information on how to set the format, please see http://windows.microsoft.com/en-US/windows-vista/Change-the-display-of-dates-times-currency-and-measurements

If you are using a language such as Chinese, and do not set both the locale and format to Chinese, then Vivado (start_gui) will crash.

For more information on Locale, see http://windows.microsoft.com/is-IS/windows7/Change-the-system-locale

Linked Answer Records

Associated Answer Records

Answer Number Answer Title Version Found Version Resolved
57386 Vivado - "Error when launching vivado.bat: Launcher time out" N/A N/A
AR# 52990
Date Created 11/16/2012
Last Updated 05/21/2014
Status Active
Type General Article
  • Vivado Design Suite