UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 59025

XADC Wizard v3.0 – Incorrect FIFO depth allowed which can cause problems when upgrading to v3.1, "ERROR: [IP_Flow 19-3458] ..."

Description

If updating to v3.1 of the XADC Wizard, the following error occurs:

ERROR: [IP_Flow 19-3458] Validation failed for parameter 'FIFO Depth(FIFO_DEPTH)' for IP 'xadc_wiz_0'. Value '1' is out of the range (7,1020)

Solution

XADC Wizard v3.0 (delivered in Vivado Design Suite 2013.2) allowed an invalid setting of the FIFO depth, if Enable AXI4Stream is set to 'True', and the design is being upgraded to Vivado 2013.3 or Vivado 2013.4 design tools.

The following error occurs:

ERROR: [IP_Flow 19-3458] Validation failed for parameter 'FIFO Depth(FIFO_DEPTH)' for IP 'xadc_wiz_0'. Value '1' is out of the range (7,1020)To correct this issue, the FIFO depth setting cannot be set from 1 -> 6; the valid range is 7 to 1020.

This issue can be seen when upgrading any Vivado project with an XADC core v3.0 to any newer version of the XADC Wizard.

AR# 59025
Date Created 01/09/2014
Last Updated 01/13/2014
Status Active
Type General Article
Devices
  • Artix-7
  • Artix-7Q
  • Kintex-7
  • More
  • Kintex-7Q
  • Virtex-7
  • Virtex-7Q
  • Less
IP
  • XADC Wizard