We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 63652

2014.4 Sysgen - Xilinx blocksets missing from Simulink Library Browser


I have installed Sysgen 2014.4 and it has launched properly from the Start Menu.

However, when I open the Simulink Library Browser, the Xilinx blocksets are missing.

I can see the path to the Vivado install in my Matlab path.

Also, I can right-click whitespace in a new model and add Sysgen blocks with the 'Xilinx Block Add...' dialog.

What is the cause of this issue?


This is a known issue discovered in Vivado 2014.4 for some environments and is fixed in the 2015.1 release.

To work around the issue, follow these steps:

1) Make sure to close down Sysgen/Matlab

2) Copy the attached script to C:\Xilinx\Vivado\2014.4\scripts\sysgen\matlab

3) Launch Sysgen as normal from the Start Menu/desktop shortcut.

4) In the Matlab console, navigate to C:\Xilinx\Vivado\2014.4\scripts\sysgen\matlab

5) Execute the script that you just copied*

6) Close Sysgen/Matlab

7) Launch Sysgen as normal from the start menu/desktop shortcut

8) Launch Simulink

9) From the Simulink Library Browser, select 'View' -> 'Refresh Tree View'

* You may see some warnings while this script is running. 

This is normal and they can be ignored.


Associated Attachments

Name File Size File Type
enableLBScript.m 345 Bytes M
AR# 63652
Date Created 02/20/2015
Last Updated 02/23/2015
Status Active
Type General Article
  • Vivado Design Suite
  • Vivado Design Suite - 2014.4
  • System Generator for DSP