We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 6592

4.2i Foundation - Btrieve incompatibility with Macola 7.5


Keywords: Macola, Btrieve, Foundation

Urgency: Standard

General Description:
Foundation does not work if the system has Macola 7.5 database software installed. Macola software renames and moves a number of DLLs; subsequently, Foundation cannot find these DLLs.

The following files were renamed in the WINNT/SYSTEM32 directory, and new files were placed into the WINNT/SYSTEM directory:


(NOTE: The order of installation is unimportant.)


The Macola 7.5 installs the Btrieve Version 7 client, which is not compatible with Xilinx Btrieve version 6. However, the Macola 7.5 server supports the Macola Version 6 client; therefore, you may delete the files installed by Macola SQL server and replace them with Btrieve Version 6 files.

For more information, please see (Xilinx Answer 3395).
AR# 6592
Date Created 05/21/1999
Last Updated 08/12/2003
Status Archive
Type General Article