UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 66899

2015.4 Licensing - Serving activation licenses with lmgrd v11.13.1.3 and TS v11.13.1.3 makes the licenses untrusted

Description

I have activation licenses on a server stored in v11.13.1.3 Trusted Storage.

These licenses are being served with lmgrd v11.13.1.3 and it appears that they have become untrusted. However, they can still be checked out.

For example, I see the following when checking the licenses on the server:

[user1]$ /tools/flexlm_v11.13.1.3/lnx64.o/xlicsrvrmgr.sh -v
Viewing server trusted storage.
U if untrusted
. D if disabled
. . fulfillmentType
. . . Expiry   Count FulfillmentId                   ProductId

U . 6 permanent    5 FID_20160307063937              PID_20160307063937

Viewed 1 of 1 fulfillment records.
[user1]$  8:24:51 (xilinxd) TCP_NODELAY NOT enabled
 8:24:51 (xilinxd) UNSUPPORTED: "xc7vx485t" (PORT_AT_HOST_PLUS   ) [user1]  (License server system does not support this feature. (-18,327))
 8:24:53 (xilinxd) UNSUPPORTED: "xc7vx485t" (PORT_AT_HOST_PLUS   ) [user1]  (License server system does not support this feature. (-18,327:104 "Connection reset by peer"))
 8:24:54 (xilinxd) UNSUPPORTED: "virtex7" (PORT_AT_HOST_PLUS   ) [user1]  (License server system does not support this feature. (-18,327:104 "Connection reset by peer"))
 8:24:56 (xilinxd) UNSUPPORTED: "virtex7" (PORT_AT_HOST_PLUS   ) [user1]  (License server system does not support this feature. (-18,327:104 "Connection reset by peer"))
 8:24:57 (xilinxd) OUT: "Vivado_Design_Edition" [user1]
 8:24:57 (xilinxd) OUT: "Synthesis" [user1]5
 8:25:11 (xilinxd) IN: "Synthesis" [user1]
 8:25:11 (xilinxd) IN: "Vivado_Design_Edition" [user1]

And this is from the client:

Checkout succeeded: Synthesis/4EABC677DCF7
        License file: 2100@myserver
        License Server: 2100@myserver

This issue has been seen on RedHat 7, CentOS, SUSE 12 and Ubuntu 14. It was not observed on other supported operation systems.

Is this expected behavior? How can I resolve this problem?

Solution

This issue has been seen on RedHat 7, CentOS, SUSE 12 and Ubuntu 14. It was not observed on other supported operating systems.

The problem also does not occur if the activation license is being served from a v11.11.x trusted storage area.

As the licenses can still be checked out or borrowed, there should be no problem using the license.

However, if you need to return the license, you will need to follow the steps below:

  1. Create a repair_request.xml file using:
    • xlicsrvrmgr -cr repair_request.xml -repairAll
  2. Check that the repair request is "trusted" by using xlicsrvrmgr -l
  3. Send the repair_request.xml to Xilinx Technical Support to generate a repair_response.xml file
  4. Apply the response using:
    • xlicsrvrmgr -p repair_response.xml
  5. Run the steps listed in (Xilinx Answer 60525) to return the license.

AR# 66899
Date Created 03/28/2016
Last Updated 04/13/2016
Status Active
Type Known Issues
Tools
  • Vivado Design Suite - 2015.4