UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 68478

DMA Subsystem for PCI Express / UltraScale+ PCI Express Integrated Block (Vivado 2016.4) - x16 Support in xczu7ev (fbv900 and ffvc1156) Devices

Description

Version Found: v1.1 (Rev3) - UltraScale+ PCI Express Integrated Block / 3.0 (Rev 1) - DMA Subsystem for PCI Express

Version Resolved and other Known Issues: (Xilinx Answer 65751) / (Xilinx Answer 65443)

The patches provided with this answer record resolve an issue with xczu7ev (fbv900 and ffvc1156) devices where an x16 core is generated with incorrect GT Quads.

There are two patches provided with this answer record: pcie4_vivado.zip and xdma_vivado.zip.

For DMA Subsystem for PCI Express, both patches must be installed. For UltraScale+ PCI Express Integrated Block, install only the pcie_vivado.zip patch.


This article is part of the PCI Express Solution Centre

(Xilinx Answer 34536)Xilinx Solution Center for PCI Express

Solution

This is a known issue to be fixed in a future release of the core, please install the tactical patches attached as described below:

METHOD 1:

  1. Navigate to the $XILINX_VIVADO/patches directory (create this directory if it does not exist)
  2. Extract the contents of the ".zip" archive to a directory starting with the name AR68478
    Note: most extraction tools will allow you to automatically create a directory with the same name as the zip file
  3. Run Vivado software tools from the original install location.


METHOD 2:

  1. Create a separate directory for the patched files
  2. Extract the contents of the ".zip" archive to the desired patch directory location
  3. Set the MYVIVADO environment variable to point to the Vivado directory under this patch directory
    For example:
    set MYVIVADO=C:\MYVIVADO\vivado-patch-AR68478\vivado\
  4. Run Vivado software tools from the original install location.

Note: "Version Found" refers to the version where the problem was first discovered.

The problem might also exist in earlier versions, but no specific testing has been performed to verify earlier versions.

Revision History

02/03/2017 - Initial release

Attachments

Associated Attachments

Name File Size File Type
AR68478_pcie4_vivado.zip 1 MB ZIP
AR68478_xdma_vivado.zip 2 MB ZIP
AR# 68478
Date 02/27/2017
Status Active
Type Known Issues
IP
  • DMA for PCI Express (PCIe) Subsystem
  • UltraScale+ FPGA Integrated Endpoint Block for PCI Express
Page Bookmarked