We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 789

How to simulate with Workview Office and XACTstep 6.0.1


Keywords: workview office, XACT, simulate, functional, timing, xsimmake

Urgency: Standard

General Description: Because XACTstep 6.0.1 was developed before Workview Office
was available, there is no automated tool for simlation like the PROflow utility.

The following steps will help get you running both functional and timing
simulations. This applies to Workview Office 7.1.2 and 7.2 within Windows
versions 3.x, 95, and NT (check Solution Record 902 for more NT information).


The first thing that must be done is to download the proper XSIMMAKE patch
from the FTP site. For Workivew Office versions 7.2 and earlier (except
7.1.2), the file is http://www.xilinx.com/txpatches/pub/swhelp/viewlogic/wvosim.zip,
and for Workview Office versions 7.3 and later, the file is

Workview Office 7.1.2 runs only on Windows 3.x and does not require a patch.
Follow the directions in the readme file.

Functional Simulation:

To functionally simulate a design that is comprised only of design elements
from the target family library (xc4000e, for example) and primary libraries,
the flow is simple. This means there are no XBLOX or XABEL modules, no CLB
primitives, no XNF files instantiated, just primitives and macros along with
user-defined hierarchy. Just select Tools -> Create Digital Netlist within
ViewDraw, and this will compile the VSM netlist, launch ViewSim and ViewTrace,
and even run a command file.

If your design does have elements that need to be compiled, like XBLOX and the
others mentioned above, you will have to run XSIMMAKE. Within windows, there
is a tool within the XACTstep toolset called the Simulation Utility that will
run this DOS program. Select the top level schematic, family, parttype, and
functional flow for Viewlogic, then press okay. This will create a new
simulation design with the name SDESIGN.

Aside: SDESIGN refers to the top-level name of your design prepended with
the letter "S".

It will also create a new directory of the same name and add this path to your
VIEWDRAW.INI. However, because the Workview Office Project Manager does not
know about xsimmake, the libraries listed in the Project Manager will not be
updated. You will have to do this by hand, but this only needs to be done
once. First close all Workview Office tools. Then open the Project Manager
and select Project -> Libraries. Create a new library with the following

Path: .\sdesign
Alias: sdesign
Type: writable

Hit the ADD button, select this new library, and use the MOVE UP button to
place it second on the list, just below the Primary library. Hit OK then
save this .vpj.

Now you can go into ViewDraw and open the SDESIGN.1 schematic (it's in the
SDESIGN library). Use this to simulate. You can launch ViewSim by hand or
use Create Digital Netlist here. It doesn't matter if we recreate the VSM
file, as this will all be unit-delay model simulation.

Timing Simulation:

The first thing you'll need to do is place and route your design. When you do
so, be sure to check the following option within the Flow Engine. Select
Setup -> Options and check the "Produce Timing Simulation Data" box.

Then after the design has been placed, routed and timed, you'll go back to the
Simulation Utility and run this again, but this time you'll select the Timing
Simulation button. If you did not run this tool for the Functional Simulation,
you must do so now, immediately followed by the Timing flow. The Xsimmake
timing flow requires things that the functional flow sets up, like the Sdesign
and the original SDESIGN.VSM file. You don't need to actually functionally
simulate, just run the utility.

Next, open the SDESIGN.1 in ViewDraw, but this time do NOT use the Create
Digital Netlist option. Instead, open ViewSim via its icon and use the
Tools -> Load VSM netlist option to bring in SDESIGN.VSM. Run your command
file just like you did with the functional simulation. If you do not see
your values annotated to the SDESIGN in Viewdraw, run this command in ViewSim:


You can put this command in your command file. This is only required for the
versions of Workview Office that have installed the XSIMMAKE patch. It is
required whenever the name within the .VSM file does not match the name of the
schematic that you are trying to annotate.
AR# 789
Date Created 08/31/2007
Last Updated 10/01/2008
Status Archive
Type General Article