UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 8915

Install - Can I run multiple versions of ISE on the same machine? (Co-existence issues regarding Xilinx ISE design tools)

Description

Can I run multiple versions of the Xilinx ISE design tools on the same machine?

Solution

Yes, it is possible to run multiple versions of ISE on a single machine. 

Installing a newer version of ISE (e.g., 11.1) does not affect the installation of prior versions (e.g., 10.1). 

They can co-exist on the same machine without a problem. 

For ISE Design Suite 11.x and earlier, if you are using an ISE Design Suite tool other than ISE, you need to ensure that the $XILINX variable is still set and pointing to your ISE installation so that those tools that interact with ISE work correctly. 

If you are using ISE Design Suite 12.1, the information below is accurate for ISE Design Suite along with ISE as long as you are using the Windows Start Menu or desktop icon.  

For terminal/command prompt use, source the settings[32|64].[bat|(c)sh] script prior to running the tools.

Running Graphical User Interfaces

  • If you are using ISE 10.1 or later, launch the GUI application executable for the version of the tool you wish to use.
    There is no need to manage environment variables or other system settings when using any ISE application after 10.1.
     
  • If you are using ISE 7.1i through 9.2i, you can launch ise(.exe) for the version of the tools you wish to use.
    There is no need to manage environment variables or other system settings when using Project Navigator.
     
  • If you are using ISE 6.3i or older, you must manage your $XILINX / $PATH (and $LD_LIBRARY_PATH on Linux) environment variables to point to the correct version. 

Running command-line 

  • If you are using ISE 10.1 to 11.1, simply launch the application executable for the version of the tools you wish to use from the correct location (C:\Xilinx\11.1\bin\nt).
    There is no need to manage environment variables or other system settings when using any ISE application after 10.1, although setting your $PATH variable would make launching from the command-prompt easier and not require launching the application from the folder where it resides.
     
  • If you are using ISE 9.2i or earlier, you must manually manage the $XILINX / $PATH (and $LD_LIBRARY_PATH on Linux) environment variables to point to the version of ISE you are currently running.
    Changing directory names rather than changing the environment variables is not supported.
    For more information on setting environment variables, see (Xilinx Answer 11630)

Attachments

Associated Attachments

Name File Size File Type
drivers.zip 119 KB ZIP
perftest.tcl 24 KB TCL
helloworld.c 3 KB C
AR# 8915
Date Created 08/21/2007
Last Updated 08/11/2014
Status Active
Type General Article
Tools
  • ISE - 10.1
  • ISE Design Suite - 11.1
  • ISE Design Suite - 11.2
  • More
  • ISE Design Suite - 11.3
  • ISE Design Suite - 11.4
  • ISE Design Suite - 11.5
  • ISE Design Suite - 12.1
  • ISE Design Suite - 12.2
  • ISE Design Suite - 12.3
  • Less