UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 9981

3.x FPGA Express - Error: "Cannot check out an appropriate license for FPGA Express/FLEXlm error: -5,357"

Description

General Description:

When I attempt to run FPGA Express in stand-alone mode, the following error messages are reported:

"Cannot check out an appropriate license for FPGA Express!"

If I attempt to check out the license several times, several error messages similar to the following are reported:

"ERROR STRING: No such feature exists

Feature: FPGA-Express

License path: <path>\license.dat

FLEXlm error: -5,357"

Solution

This problem is due to an improper package line in the license file. You can work around this issue by copying the following package line and replacing it in your current license file:

(NOTE: For Foundation (Aldec version) users, the increment line must include "FND-BSX-PC".)

PACKAGE FND-BSX-PC xilinxd 1.000 A01010113F5D598EAD98 \

COMPONENTS="FPGA-Express:2001.09 \

FPGA-Express-VHDL-Base:2001.09 \

FPGA-Express-VLOG-Base:2001.09 \

FPGA-Express-XC3k-Optimizer:2001.09 \

FPGA-Express-XC4k-Optimizer:2001.09 \

FPGA-Express-XC5k-Optimizer:2001.09 \

FPGA-Express-VIRTEX-Optimizer:2001.09 \

FPGA-Express-XC9k-Optimizer:2001.09 "

(NOTE: For Foundation ISE users, the increment line must include "FSE-BSX-PC".)

PACKAGE FSE-BSX-PC xilinxd 1.000 E01060210AE6AB3621CF \

COMPONENTS="FPGA-Express:2001.09 \

FPGA-Express-VHDL-Base:2001.09 \

FPGA-Express-VLOG-Base:2001.09 \

FPGA-Express-XC3k-Optimizer:2001.09 \

FPGA-Express-XC4k-Optimizer:2001.09 \

FPGA-Express-XC5k-Optimizer:2001.09 \

FPGA-Express-VIRTEX-Optimizer:2001.09 \

FPGA-Express-XC9k-Optimizer:2001.09 "

AR# 9981
Date Created 08/31/2007
Last Updated 05/14/2010
Status Archive
Type General Article