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Figure 18: Closer View of the Pblock Area 

7. In the Set Pblock dialog box, verify that SLICE and DSP48 are checked as the resources to be 

reconfigured, shown in the following figure. 

8. Click OK. 
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Figure 19: Setting Pblock with SLICE and DSP48 
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Step 7: Running the Design Rule Checker 

Xilinx recommends that you run a Design Rule Check (DRC) in order to detect errors as soon as 

possible. 

Selecting and Running PR-specific DRCs 

1. Select Tools > Report DRC. 

2. Deselect All Rules. 

3. Select Partial Reconfig. 

4. Click OK to run the PR-specific design rules. 

 

Figure 20: Running Design Rule Checks 

You will see warnings stating that Reconfigurable Modules (RMs) have not been 

implemented. 
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Step 8: Creating the First Configuration, Implementing, 
and Promoting 

Now you can create and implement the first configuration.  

Creating a New Strategy 

Use the -bm option pointing to the system.bmm file for the new strategy. 

1. Select Tools > Options. 

2. Select Strategies in the left pane. 

3. Select ISE 14 in the Flow drop-down box. 

4. Under PlanAhead Strategies, select ISE Defaults. 

5. Click the + button to create a new strategy. 

 

Figure 21: Creating a New Strategy 

6. Name the new strategy ISE14_BM, and set the Type to Implement. 

7. Click OK. 

8. Under Translate (ngdbuild), click in the More Options field.  

9. Type -bm ../../../edk/implementation/system.bmm, and click Apply. 

10. Click OK. 
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Running the Implementation Using Mult as a Variant 

1. At the bottom of the PlanAhead tool user interface, select the Design Runs tab. 

2. Select the config_1 run. 

3. In the Implementation Run Properties window, select the General tab. 

4. In the Name field, type mult as the run name. 

5. Click Apply to change the run name from config_1 to mult.  

 

Figure 22: Implementation Run Properties View 

6. In the Options tab, change the Strategy to ISE14_BM. 

7. Click Apply.  

8. In the Partitions tab, click the Module Variant column drop-down button and select mult as 

the variant. 

9. Click Apply. 

http://www.xilinx.com/
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Figure 23: Implementation Run 

10. In the Sources window, expand Reconfigurable Module Sources entry and expand mult 

entry, if needed, right-click on rp.ngc, and select Replace File… to reload the same rp.ngc 

file. 

Note: On the Windows version of the tools, you will need to reload the Reconfigurable 

Module’s ngc file which will be implemented next. You do not need to do this step when the 

black box is the RM.  

11. Browse to the same folder and click OK to load the  the file. 

12. In the Netlist window, make the corresponding module (mult) active, right-clicking on its 

entry and selecting Set As a Active Reconfigurabe Module. 

You can confirm whether the correct RM is loaded or not by selecting the RP and then right 

clicking on the RP in the Device view window and selecting Schematic. 

13. In the Design Run window, select mult, and right-click and select Launch Runs to run the 

implementation. 

14. Select Launch Runs on Local Host. 

15. Click OK. 

16. Click Save (if a dialog box shows up) to save the project and run the implementation. 

The implementation runs.  

When implementation is finished running, the Implementation Completed dialog box opens 

to let you open the implemented design, or promote the implemented partitions. 

http://www.xilinx.com/
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17. Select the Promote Partitions radio button, and click OK. 

18. In the Promote Partitions dialog box, click OK to promote the current configuration so the 

implemented results are available for the subsequent configurations. 

 

Figure 24: Promoting Partitions 
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Step 9: Creating Other Configurations, and 
Implementing 

After you have created the first configuration, the static logic implementation is reused for the 

rest of the configurations. Next, you will create the desired number of additional configurations 

and implement them. 

Make the Second Reconfigurable Module Active  

Note: In the Windows version of the tool, you must load the netlist of the active RM.  

1. In the Netlist window, expand the math_0 > math_0 > Reconfigurable Modules and right-

click on the adder, and select Set As a Active Reconfigurabe Module. 

2. In the Sources window, expand reconfigurable Module Sources entry and expand adder 

entry, if needed, right-click on rp.ngc, and select Replace File… to reload the same rp.ngc 

file. 

3.  Browse to the original location, select the rp.ngc file, and click OK. 

4. Click on Reload as the netlist has changed. 

Note: You do not need to do this for a black box instance, as there is no ngc file associated 

with that RM. 

Also note: If you have more than two RMs, then on Windows, you cannot create and run 

multiple runs as shown in the next section, Creating Multiple Runs. Instead, you will have to 

make one RM active, reload the corresponding ngc file, create a run, and run the 

implementation for each RM until only one RM and a black box are left.  

Creating Multiple Runs 

1. Select Flow > Create Runs. 

The Create New Runs window opens. 

2. Click Next twice. 

3. In the Choose Implementation Strategies and Reconfigurable Modules page, change the 

name of the configuration from config_1 to adder. 

4. Click More. 

5. Change the name of config_1 to black_box. 

http://www.xilinx.com/
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Figure 25: Creating Multiple Runs 

6. In the adder configuration row, click the Partition Action field. 

7. For the rp_instance row, click the Module Variant column drop-down arrow, and select 

adder as the variant to be implemented, as shown in Figure 26. 

http://www.xilinx.com/
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Figure 26: Selecting Adder Module Variant 

8. Click OK. 

9. Similarly, select math_BB variant for the black_box run (row). 

10. Click Next. 

11. Select Launch Runs on Local Host. 

12. Click Next. 

13. Click Finish to run the implementations for both configurations. 

14. Click Cancel when the runs are finished. 
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Step 10: Running Partial Reconfiguration to Verify 
Utility 

Next, you will check to be sure that the static implementation, including interfaces to 

reconfigurable regions, is consistent across all configurations. To verify this, you can run the 

PR_Verify utility. 

Running the PR_Verify Utility 

1. Run the PR_Verify utility to make sure that there are no errors. 

2. In the Configurations window, select any of the configurations. 

3. Right-click, and select Verify Configuration. 

 

Figure 27: Verifying All Configurations 

4. Press Shift and select all configurations. 

5. Click OK. 

6. The PR_Verify utility runs and reports that there were no errors. 
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Step 11: Generating Bit Files 

After PR_Verify validates all the configurations, you can generate full and partial bit files for the 

entire project.  

Generating Full and Partial Bitstreams 

1. In the Design Runs window, press Shift and select the following three designs runs: 

 mult 

 adder 

 black_box 

2. Right-click and select Generate Bitstream. 

This runs the bitstream generation process and generates full and partial bitstreams. 

The bit files are placed in the mult, adder and black box directories under the 

<Extract_Dir>/PlanAhead/PlanAhead.runs/ directory. 

3. Click OK. 

4. Save the project. 

5. Close PlanAhead by selecting File > Exit. 
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Step 12: Creating an Image, and Testing 

For this step you need to open an EDK shell, and create both a download.bit and a 

system.ace file in the image/ directory. Copy the generated partial bit files, place them in the 

image/ directory, and name them adder.bit, mult.bit, and blank.bit. 

Renaming Partial Bitstream Files, and Generating the system.ace File 

1. Launch the ISE Design Suite command prompt from your Windows environment by selecting 

Start > All Programs > Xilinx Design Tools > Xilinx ISE Design Suite > Accessories > ISE 

Design Suite Command Prompt. 

2. In the command window, go to the <Extract_Dir>/image/ directory. 

3. Execute the following command to generate the download.bit file (with the software 

component included) from adder.bit (with the hardware component) only. 

data2mem -bm ../edk/implementation/system_bd  

-bt ../PlanAhead/PlanAhead.runs/adder/adder.bit  

-bd ../edk/SDK/SDK_Export/TestApp/Debug/TestApp.elf tag microblaze_0 –o b 

download.bit 

Hint: Copy the command text from this document and paste it in the shell or command 

window by right-clicking and selecting Paste. 

This generates the download.bit in the image/ directory. 

4. In the Bash shell, execute the following command to generate the system.ace file in the 

image/ directory. 

xmd -tcl genace.tcl -jprog -target mdm -hw download.bit -board ml605 -ace 

system.ace 

5. Using Windows Explorer, copy and rename the following files, as shown in the following 

table. 

  

http://www.xilinx.com/


 Step 12: Creating an Image, and Testing 

Partial Reconfiguration of a Processor Tutorial  www.xilinx.com  40 

UG744 (v14.5) April 25, 2013 

File Name Copy to  

Directory 

Rename File To 

<Extract_Dir>/PlanAhead/PlanAhead.runs/adder/ 

adder_math_0_math_0_user_logic_i_rp_instance_ad

der_partial.bit 

/image adder.bit 

<Extract_Dir>/PlanAhead/PlanAhead.runs/mult/m

ult_math_0_math_0_user_logic_i_rp_instance_mult_

partial.bit 

/image mult.bit 

<Extract_Dir>/PlanAhead/PlanAhead.runs/black_b

ox/black_box_math_0_math_0_user_logic_i_rp_inst

ance_math_bb_partial.bit 

/image blank.bit 

Copying the system.ace and Three Partial Bit Files on a Compact Flash 
Memory Card 

1. Place a blank Compact Flash memory card in a Compact Flash writer. 

2. Using Windows Explorer, copy the three partial bit files and the system.ace file from 

<Extract_Dir>/image/ folder to the Compact Flash card. 

3. Place the Compact Flash card in the ML605 board. 

4. Set the SACE Mode pins (S1) to 0111 (dn-up-up-up) to configure the FPGA device from the 

Compact Flash. 

5. Connect your PC to the ML605 with the provided USB cable. 

6. Install the driver, if necessary. For instructions, see the ML605 Hardware User Guide: 

http://www.xilinx.com/support/documentation/boards_and_kits/ug534.pdf 

7. Start a HyperTerminal window, connecting using COMx at 115200 baud and power ON the 

ML605 board. 

8. Press CPU Reset. 

9. Follow the menu and test various reconfigurations. 

Typing O at the menu will let you enter two operands and display the results.  Typing M, B, 

or A at the menu will let you partially reconfigure the multiplication, blanking, addition 

functionality respectively. 

Try various reconfigurations and enter operands after each reconfiguration to verify that the 

design indeed works. 

When blanking bitstream is loaded, you should see the output of -1 as there is no logic 

present in the reconfigurable partition to perform the operation. 

http://www.xilinx.com/
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Conclusion  

In this tutorial, you: 

 Created a processor system using XPS. 

 Added a user peripheral which included a place holder for the reconfigurable partition. 

 Generated netlist files.  

 Created an application using SDK.  

 Generated a full bitstream as well as partial reconfiguration bitstreams using the 

PlanAhead tool.  

 Generated an ACE file for Compact Flash memory card.  

 Verified the functionality using the ML605 evaluation board. 
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