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Chapter 7: Timing Simulation

Timing Simulation Using Xilinx ISim
Follow this section of the tutorial if you have skipped the previous section, Timing 
Simulation Using ModelSim.

Specifying Simulation Process Properties
To set the simulation process properties, do the following:

1. In the View pane of the Project Navigator Design panel, select Simulation, and select 
Post-Route from the drop-down list.

2. In the Hierarchy pane, select the test bench file (stopwatch_tb). 

3. In the Processes pane, expand ISim Simulator, right-click Simulate Post-Place & 
Route Model, and select Process Properties. 

4. In the Process Properties dialog box, ensure that the Property display level is set to 
Advanced.

This global setting enables you to see all available properties.

5. Select the Simulation Model Properties category. These properties set the options that 
NetGen uses when generating the simulation netlist. For a description of each 
property, click the Help button.

For this tutorial, the default Simulation Model Properties are used.

6. Select the ISim Properties category. These properties set the options the simulator 
uses to run the timing simulation. For a description of each property, click the Help 
button.

The properties should appear as shown in the following figure. Set the Simulation Run 
Time property to 2000 ns.

7. Click OK to close the Process Properties dialog box.

X-Ref Target - Figure 7-11

Figure 7-11: Simulation Properties
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Performing Simulation
To start the timing simulation, double-click Simulate Post-Place and Route Model in the 
Processes pane.

When a simulation process is run, Project Navigator automatically runs NetGen to 
generate a timing simulation model from the placed and routed design. The ISim then 
compiles the source files, loads the design, and runs the simulation for the time specified.

Note: The majority of this design runs at 100 Hz and would take a significant amount of time to 
simulate. This is why the counter will seem like it is not working in a short simulation. For the purpose 
of this tutorial, only the DCM signals will be monitored to verify that they work correctly.

Adding Signals

To view signals during the simulation, you must add them to the waveform window. The 
ISE software automatically adds all the top-level ports to the waveform window. All 
available external (top-level ports) and internal signals are displayed in the simulation 
hierarchy.

The following procedure explains how to add additional signals in the design hierarchy. In 
this tutorial, you will be adding the DCM signals to the waveform.

1. In the Instances and Processes panel, expand the stopwatch_tb hierarchy. 

2. Expand the UUT hierarchy.

3. Locate and select Inst_dcm1_DCM_SP_INST

4. In the Objects window, select the locked signal, and click on Add to Wave Window.

The following figure shows the Simulation Instances and Simulation Objects window 
for the VHDL flow. The signal names and layout in the Simulation Instances window 
for a schematic or VHDL flow may be different.

X-Ref Target - Figure 7-12

Figure 7-12: Simulation Instances and Simulation Objects Windows—VHDL Flow
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5. Click and drag the following X_DCM_SP signals from the simulation hierarchy to the 
waveform window:

• RST

• CLKFX

• CLK0

• CLKIN

Note: Multiple signals can be selected by pressing the Ctrl key.

Viewing Full Signal Names

A signal name can be viewed using either the complete hierarchical name or the short 
name, which omits hierarchy information. To change the signal name display, do the 
following:

1. Right-click the desired signal in the waveform window.

2. Select Name > Long or Name > Short.

Stretch the first column in the waveform to see the signals clearly. 

The waveform should appear as shown in the following figure.

Notice that the waveforms have not been drawn for the newly added signals. This is 
because ISim did not record the data for these signals. ISim only records data for the 
signals that are added to the waveform window while the simulation is running. 
Therefore, after new signals are added to the waveform window, you must rerun the 
simulation for the desired amount of time.

X-Ref Target - Figure 7-13

Figure 7-13: Resulting Waveform

http://www.xilinx.com
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Rerunning Simulation

To restart and rerun the simulation, do the following:

1. Click the Restart Simulation toolbar button.

2. At the Sim Console command prompt, enter run 2000 ns and hit the Enter key.

The simulation will run for 2000 ns. The waveforms for the DCM should now be visible in 
the Simulation window.

Analyzing the Signals

Now the DCM signals can be analyzed to verify that they are working as expected. The 
CLK0 must be 50 Mhz and the CLKFX should be approximately 26 Mhz. The DCM signals 
should only be analyzed after the LOCKED signal has gone high. Until the LOCKED signal 
is high the DCM outputs are not valid.

ISim has the capability to add cursors to carefully measure the distance between signals. To 
measure the CLK0, do the following:

1. If necessary, zoom in on the waveform using the local Zoom toolbar buttons. 

2. In the local waveform viewer toolbar, click the Snap to Transition toolbar button.

3. Click on the first rising edge transition on the CLK0 signal after the LOCKED signal 
has gone high, then drag the cursor to the right to the next rising edge transition of the 
CLK0 signal.

At the bottom of the waveform window, the start point time, end point time, and delta 
times are shown. The delta should read 20.0 ns. This converts to 50 Mhz, which is 

X-Ref Target - Figure 7-14

Figure 7-14: Restart Simulation Icon

X-Ref Target - Figure 7-15

Figure 7-15: Entering the Run Command

X-Ref Target - Figure 7-16

Figure 7-16: Snap to Transition Toolbar Button

http://www.xilinx.com
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the input frequency from the test bench, which in turn should be the DCM CLK0 
output.

4. Measure CLKFX using the same steps as above. The measurement should read 38.5 
ns, this equals approximately 26 Mhz. 

Your timing simulation is complete and you are ready to program your device by 
following Chapter 8, Configuration Using iMPACT.

X-Ref Target - Figure 7-17

Figure 7-17: Waveform Viewer Displaying Time Between Transitions

http://www.xilinx.com
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Configuration Using iMPACT

Overview of iMPACT
This chapter takes you on a tour of iMPACT, a file generation and device programming 
tool. iMPACT enables you to program through several parallel cables, including the 
Platform Cable USB. iMPACT can create bitstream files, System ACE™ solution files, 
PROM files, and SVF/XSVF files. The SVF/XSVF files can be played backed without 
having to recreate the chain.

Device Support
For information on supported devices, refer to the ISE Design Suite: Release Notes Guide 
(UG631) available from the Xilinx® website.

Download Cable Support
The following cables are supported.

Parallel Cable IV
The Parallel Cable connects to the parallel port of your computer and can be used to 
facilitate Boundary-Scan functionality. For more information, see the Xilinx Parallel Cable 
IV Data Sheet available from the Xilinx website.

Platform Cable USB
The Platform Cable connects to the USB port of your computer and can be used to facilitate 
Boundary-Scan functionality. For more information, see the Platform Cable USB Data 
Sheet available from the Xilinx website.

Platform Cable USB-II
The Platform Cable connects to the USB port of your computer and can be used to facilitate 
Boundary-Scan functionality. For more information, see the Platform Cable USB-II Data 
Sheet available from the Xilinx website.

Configuration Mode Support
iMPACT currently supports the Boundary-Scan configuration mode for FPGAs, CPLDs, 
PROMs (XCFxxS and XCFxxP), and third-party SPI/BPI Flash devices.

http://www.xilinx.com/cgi-bin/SW_Docs_Redirect/sw_docs_redirect?ver=13.1&locale=en&topic=release+notes
http://www.xilinx.com/cgi-bin/SW_Docs_Redirect/sw_docs_redirect?ver=13.1&locale=en&topic=release+notes
http://www.xilinx.com/cgi-bin/SW_Docs_Redirect/sw_docs_redirect?locale=en&topic=data+sheets&sub=ds097.pdf
http://www.xilinx.com/cgi-bin/SW_Docs_Redirect/sw_docs_redirect?locale=en&topic=data+sheets&sub=ds097.pdf
http://www.xilinx.com/cgi-bin/SW_Docs_Redirect/sw_docs_redirect?locale=en&topic=data+sheets&sub=ds300.pdf
http://www.xilinx.com/cgi-bin/SW_Docs_Redirect/sw_docs_redirect?locale=en&topic=data+sheets&sub=ds300.pdf
http://www.xilinx.com/cgi-bin/SW_Docs_Redirect/sw_docs_redirect?locale=en&topic=data+sheets&sub=ds593.pdf
http://www.xilinx.com/cgi-bin/SW_Docs_Redirect/sw_docs_redirect?locale=en&topic=data+sheets&sub=ds593.pdf
http://www.xilinx.com
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Getting Started
The following sections outline the requirements to perform this part of the tutorial flow.

Generating the Configuration Files
To follow this chapter, you must have the following files for the stopwatch design:

• BIT file

A binary file that contains proprietary header information as well as configuration 
data.

• MCS file

An ASCII file that contains PROM configuration information.

• MSK file

A binary file that contains the same configuration commands as a BIT file, but that has 
mask data in place of configuration data. This data is not used to configure the device, 
but is used for verification. If a mask bit is 0, the bit should be verified against the bit 
stream data. If a mask bit is 1, the bit should not be verified. This file is generated along 
with the BIT file.

These files are generated in Chapter 6, Design Implementation.

The tutorial project files are provided with the ISE Design Suite Tutorials available from 
the Xilinx website. Download the project files for the VHDL, Verilog, or schematic design 
flow.

Connecting the Cable 
Prior to launching iMPACT, connect the parallel side of the cable to your computer’s 
parallel port, and connect the cable to the Spartan™-3 Starter Kit demo board. Be sure that 
the board is powered.

Starting the Software
This section describes how to start the iMPACT software from the ISE® software and how 
to run the iMPACT software standalone.

http://www.xilinx.com
http://www.xilinx.com/cgi-bin/SW_Docs_Redirect/sw_docs_redirect?locale=en&ver=13.1&topic=ise+tutorials
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Opening iMPACT from Project Navigator

To start iMPACT from Project Navigator, double-click Manage Configuration Project 
(iMPACT) in the Processes pane in the Design panel, as shown in the following figure.

Opening iMPACT Standalone

To open iMPACT without going through an ISE project, use one of the following methods:

• PC only: Click Start > All Programs > Xilinx ISE Design Suite > ISE Design Tools > 
Tools > iMPACT.

• PC or Linux: Type impact at a command prompt.

Note: To run applications from the command line, you must configure the system environment 
to point to the ISE Design Suite. To do this, run the appropriate settings32.csh/bat or 
settings64.csh/bat file from the <XILINX installation directory>\. For more 
information, refer to the ISE Design Suite: Installation and Licensing Guide (UG798) available 
from the Xilinx website.

Using Boundary-Scan Configuration Mode
For this tutorial, you will be using the Boundary-Scan configuration mode. Boundary-Scan 
configuration mode enables you to perform Boundary-Scan operations on any chain 
comprising JTAG compliant devices. The chain can consist of both Xilinx and non-Xilinx 
devices; however, limited operations will be available for non-Xilinx devices. To perform 
operations, the cable must be connected and the JTAG pins, TDI, TCK, TMS, and TDO, 
must be connected from the cable to the board.

Specifying Boundary-Scan Configuration Mode
In iMPACT, creating a new project includes specifying the configuration mode and the 
device to program. To select Boundary-Scan Mode, do the following:

1. Select File > New Project.

2. In the Automatically create and save a project dialog box, select Yes.

3. In the Welcome to iMPACT dialog box, select Configure Devices using 
Boundary-Scan (JTAG).

4. Ensure that Automatically connect to a cable and identify Boundary-Scan chain is 
selected.

X-Ref Target - Figure 8-1

Figure 8-1: Opening iMPACT from Project Navigator

http://www.xilinx.com
http://www.xilinx.com/cgi-bin/SW_Docs_Redirect/sw_docs_redirect?ver=13.1&locale=en&topic=install
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Note: The selection box also gives you the option to Enter a Boundary-Scan Chain, which 
enables you to manually add devices to create the chain. This option enables you to generate an 
SVF/XSVF programming file and is discussed in a later section in this chapter. Automatically 
detecting and initializing the chain should be performed whenever possible. 

5. Click OK.

iMPACT will pass data through the devices and automatically identify the size and 
composition of the Boundary-Scan chain. Any supported Xilinx device will be recognized 
and labeled in iMPACT. Any other device will be labeled as unknown. The software will 
then highlight each device in the chain and prompt you to assign a configuration file or 
BSDL file.

Note: If you were not prompted to select a configuration mode or automatic Boundary-Scan mode, 
right-click in the iMPACT window and select Initialize Chain. The software will identify the chain if the 
connections to the board are working. Go to Troubleshooting Boundary-Scan Configuration if you are 
having problems.

Assigning Configuration Files
After initializing a chain, the software prompts you for a configuration file (see Figure 8-3). 
The configuration file is used to program the device. There are several types of 
configuration files:

• Bitstream file (*.bit, *.rbt, *.isc) is used to configure an FPGA.

• JEDEC file (*.jed,*.isc) is used to configure a CPLD. 

• PROM file (*.mcs, *.hex) is used to configure a PROM.

When the software prompts you to select a configuration file for the first device 
(XC3S700A), do the following:

1. Select the BIT file from your project working directory.

2. Click Open.

You should receive a warning stating that the startup clock has been changed to 
JtagClk.

X-Ref Target - Figure 8-2

Figure 8-2: Selecting Automatic Boundary-Scan Using iMPACT Wizard

http://www.xilinx.com
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3. Click OK.

The following figure shows configuration file selection. 

Note: If a configuration file is not available, a Boundary-Scan Description File (BSDL or BSD) 
file can be applied instead. The BSDL file provides the software with the necessary 
Boundary-Scan information that allows a subset of the Boundary-Scan operations to be 
available for that device. To have the ISE software automatically select a BSDL file (for both Xilinx 
and non-Xilinx devices), select Bypass in the Assign New Configuration File dialog box.

4. When the software prompts you to select a configuration file for the second device 
(XCF02S), select the MCS file from your project working directory.

5. Click Open. 

X-Ref Target - Figure 8-3

Figure 8-3: Selecting a Configuration File

http://www.xilinx.com
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Saving the Project File
After the chain has been fully described and configuration files are assigned, you should 
save your iMPACT Project File (IPF) for later use. To do this, select File > Save Project As. 
The Save As dialog box opens, and you can browse and save your project file accordingly. 
To restore the chain after reopening iMPACT, select File > Open Project and browse to the 
IPF. 

Note: Previous versions of the ISE software use Configuration Data Files (CDF). These files can still 
be opened and used in iMPACT. iMPACT Project Files can also be exported to a CDF.

Editing Preferences
To edit the preferences for the Boundary-Scan configuration, select Edit > Preferences. 
This selection opens the window shown in the following figure. Click Help for a 
description of the preferences. In this tutorial, keep the default values and click OK.
X-Ref Target - Figure 8-4

Figure 8-4: Edit Preferences

http://www.xilinx.com
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Performing Boundary-Scan Operations
You can perform Boundary-Scan operations on one device at a time. The available 
Boundary-Scan operations vary based on the device and the configuration file that was 
applied to the device. To see a list of the available options, right-click on any device in the 
chain. This brings up a window with all of the available options.

When you select a device and perform an operation on that device, all other devices in the 
chain are automatically placed in BYPASS or HIGHZ, depending on your iMPACT 
Preferences setting. For more information about Preferences, see Editing Preferences. 

To perform an operation, right-click on a device and select one of the options. In this 
section, you will retrieve the device ID and run the programming option to verify the first 
device as follows:

1. Right-click on the XC3S700A device, and select Get Device ID.

The software accesses the IDCODE for this Spartan-3A device. The result is displayed 
in the log window, as shown in the following figure.

Figure X-Ref Target - Figure 8-5

Figure 8-5: Available Boundary-Scan Operations for XC3S700A Device

X-Ref Target - Figure 8-6

Figure 8-6: Log Window Showing Result of Get Device ID

http://www.xilinx.com
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2. Right-click on the XC3S700A device, and select Set Programming Properties.

The Device Programming Properties dialog box opens. 

3. Select the Verify option.

The Verify option enables the device to be read back and compared to the BIT file using 
the MSK file that was created earlier.

4. Click OK to begin programming.

Note: The options available in the Device Programming Properties dialog box vary based on 
the device you have selected.

X-Ref Target - Figure 8-7

Figure 8-7: Program Options for XC3S700A Device

http://www.xilinx.com
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5. Right-click on the XC3S700A device again, and select Program.

The Programming operation begins and an operation status window appears. At the 
same time, the log window reports all of the operations being performed.

When the Program operation completes, a large blue message appears showing that 
programming was successful, as shown in the following figure. This message 
disappears after a few seconds.

Your design has been programmed and has been verified. The board should now be 
working and should allow you to start, stop and reset the runner’s stopwatch. 

X-Ref Target - Figure 8-8

Figure 8-8: Operation Status

X-Ref Target - Figure 8-9

Figure 8-9: Programming Operation Complete

http://www.xilinx.com
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Troubleshooting Boundary-Scan Configuration
The following sections assist you with troubleshooting errors that may occur during 
Boundary-Scan operations.

Verifying the Cable Connection
When an error occurs during a Boundary-Scan operation, first verify that the cable 
connection is established and that the software auto detect function is working. If a 
connection is still not established after plugging the cable into the board and into your 
machine, right-click in a blank portion of the iMPACT window and select either Cable 
Auto Connect or Cable Setup. Cable Auto Connect will force the software to search every 
port for a connection. Cable Setup enables you to select the cable and the port to which the 
cable is connected.

When a connection is found, the bottom of the iMPACT window will display the type of 
cable connected, the port attached to the cable, and the cable speed, as shown in the 
following figure.

Note: If a cable is connected to the system and the cable autodetection fails, refer to Xilinx Answer 
Record 15742.

Verifying the Chain Setup
When an error occurs during a Boundary-Scan operation, verify that the chain is set up 
correctly and verify that the software can communicate with the devices. The easiest way 
to do this is to initialize the chain. To do so, right-click in the iMPACT window and select 
Initialize Chain. The software will identify the chain if the connections to the board are 
working.

If the chain cannot be initialized, it is likely that the hardware is not set up correctly or the 
cable is not properly connected. If the chain can be initialized, try performing simple 
operations. For example, try getting the Device ID of every device in the chain. If this can 
be done, then the hardware is set up correctly and the cable is properly connected.

X-Ref Target - Figure 8-10

Figure 8-10: Cable Connection Successful

http://www.xilinx.com
http://www.xilinx.com/cgi-bin/SW_Docs_Redirect/sw_docs_redirect?locale=en&topic=answer+record&sub=15742
http://www.xilinx.com/cgi-bin/SW_Docs_Redirect/sw_docs_redirect?locale=en&topic=answer+record&sub=15742


ISE In-Depth Tutorial www.xilinx.com 141
UG695 (v13.1) March 1, 2011

Creating an SVF File

The debug chain can also be used to manually enter JTAG commands, as shown in the 
following figure. This can be used for testing commands and verifying that the chain is set 
up correctly. To use this feature, select Debug > Enable/Disable Debug Chain in iMPACT.

For help using iMPACT Boundary-Scan Debug, use the iMPACT Help, accessible from 
Help > Help Topics. For help with troubleshooting, file a WebCase on the Xilinx website. 

Creating an SVF File
This section is optional and assumes that you have followed the Using Boundary-Scan 
Configuration Mode section and have successfully programmed to a board. In this section, 
all of the configuration information is written to the SVF file.

iMPACT supports the creation of device programming files in three formats: SVF, XSVF, 
and STAPL. If you are using third-party programming solutions, you may need to set up 
your Boundary-Scan chain manually and then create a device programming file. These 
programming files contain both programming instructions and configuration data, and 
they are used by Automatic Test Equipment (ATE) machines and embedded controllers to 
perform Boundary-Scan operations. A cable normally does not need to be connected 
because no operations are being performed on devices.

X-Ref Target - Figure 8-11

Figure 8-11: Debug Chain

http://www.xilinx.com
http://www.xilinx.com/cgi-bin/SW_Docs_Redirect/sw_docs_redirect?locale=en&topic=online+case
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Setting Up the Boundary-Scan Chain
This section assumes that you are continuing from the previous sections of this chapter and 
already have the chain detected. If not, skip to Manually Setting Up the JTAG Chain for 
SVF Generation to define the chain manually.

Setting Up the JTAG Chain for SVF Generation

To set up the JTAG chain, do the following:

1. Select Output > SVF File > Create SVF File to indicate that you are creating a 
programming file.

2. In the Create New SVF File dialog box, enter getid in the File Name field, and click 
Save.

3. An informational message appears stating that all device operations will be directed to 
the .svf file. Click OK.

Manually Setting Up the JTAG Chain for SVF Generation

For this tutorial, you may skip this section if you completed the Using Boundary-Scan 
Configuration Mode section.

The Boundary-Scan chain can be manually created or modified as well. To do this, do the 
following:

1. Ensure that you are in Boundary-Scan Mode by clicking the Boundary-Scan tab.

You can now add one device at a time.

2. Right-click on an empty space in the iMPACT Boundary-Scan window, and select Add 
Xilinx Device or Add Non-Xilinx device. 

An Add Device dialog box opens, allowing you to select a configuration file.

3. Select stopwatch.bit, and then click Open.

The device is added where the large cursor is positioned. To add a device between 
existing devices, click on the line between them and then add the new device. 

Repeat steps 2 and 3 to add the stopwatch.mcs file to the chain.

Note: The Boundary-Scan chain that you manually create in the software must match the chain on 
the board, even if you intend to program only some of the devices. All devices must be represented 
in the iMPACT window.

Writing to the SVF File
The process of writing to an SVF file is identical to performing Boundary-Scan operations 
with a cable. You simply right-click on a device and select an operation. Any number of 
operations can be written to an SVF file.

In this section, you will be writing the device ID to the programming file for the first 
device, and performing further instructions for the second device.

http://www.xilinx.com
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To write the device ID, do the following:

1. Right-click the first device (XC3S700A), and select Get Device ID.

The instructions that are necessary to perform a Get Device ID operation are then 
written to the file.

X-Ref Target - Figure 8-12

Figure 8-12: Selecting a Boundary-Scan Operation

http://www.xilinx.com
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2. To see the results, select View > View SVF-STAPL File. The following figure shows the 
SVF file after the Get Device ID operation is performed.

X-Ref Target - Figure 8-13

Figure 8-13: SVF File That Gets a Device ID from the First Device in the Chain

http://www.xilinx.com


ISE In-Depth Tutorial www.xilinx.com 145
UG695 (v13.1) March 1, 2011

Creating an SVF File

To write further instructions to the SVF for the second device, do the following:

1. Right-click the second device (XCF02S), and select Program.

2. Click OK in the Programming Properties window.

The instructions and configuration data needed to program the second device are 
added to the SVF file. 

Stopping Writing to the SVF File
After all the desired operations have been performed, you must add an instruction to close 
the file from further instructions. To stop writing to the programming file, select Output > 
SVF File > Stop Writing to SVF File.

To add other operations in the future, you can select Output > SVF File > Append to SVF 
File, select the SVF file, and click Save.

Playing Back the SVF or XSVF File
To play back the SVF file that you created to verify the instructions, do the following:

1. Manually create a new chain.

2. Assign the SVF file to the chain by right-clicking and selecting Add Xilinx Device and 
selecting the SVF file in the search window.

3. Right-click on the SVF file in the Boundary-Scan chain and select Execute XSVF/SVF.

Your device programming is complete, and you have successfully completed the ISE 
In-Depth Tutorial (UG695).

X-Ref Target - Figure 8-14

Figure 8-14: Available Boundary-Scan Operations for XCF02S Device

http://www.xilinx.com
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Appendix A

Additional Resources

Xilinx Resources
• ISE Design Suite: Installation and Licensing Guide (UG798): 

http://www.xilinx.com/support/documentation/sw_manuals/xilinx13_1/iil.pdf 

• ISE Design Suite 13: Release Notes Guide (UG631): 
http://www.xilinx.com/support/documentation/sw_manuals/xilinx13_1/irn.pdf 

• Xilinx® Documentation: 
http://www.xilinx.com/support/documentation

• Xilinx Global Glossary: 
http://www.xilinx.com/support/documentation/sw_manuals/glossary.pdf

• Xilinx Support: http://www.xilinx.com/support

ISE Documentation
• ISE Documents:

http://www.xilinx.com/support/documentation/dt_ise13-1.htm 

- Command Line Tools User Guide (UG628): 
http://www.xilinx.com/support/documentation/sw_manuals/xilinx13_1/devref.pdf

- Xilinx Synthesis and Simulation Design Guide (UG626): 
http://www.xilinx.com/support/documentation/sw_manuals/xilinx13_1/sim.pdf

- XST User Guide for Virtex-4, Virtex-5, Spartan-3, and Newer CPLD Devices 
(UG627): 
http://www.xilinx.com/support/documentation/sw_manuals/xilinx13_1/xst.pdf

- XST User Guide for Virtex-6, Spartan-6, and 7 Series Devices (UG687): 
http://www.xilinx.com/support/documentation/sw_manuals/xilinx13_1/xst_v6s6.pdf

http://www.xilinx.com
http://www.xilinx.com/cgi-bin/SW_Docs_Redirect/sw_docs_redirect?ver=13.1&locale=en&topic=install
http://www.xilinx.com/cgi-bin/SW_Docs_Redirect/sw_docs_redirect?ver=13.1&locale=en&topic=release+notes
http://www.xilinx.com/support/documentation
http://www.xilinx.com/support/documentation/sw_manuals/glossary.pdf
http://www.xilinx.com/support
http://www.xilinx.com/support/documentation/dt_ise13-1.htm
http://www.xilinx.com/cgi-bin/SW_Docs_Redirect/sw_docs_redirect?locale=en&ver=13.1&topic=sw+manuals&sub=devref.pdf
http://www.xilinx.com/cgi-bin/SW_Docs_Redirect/sw_docs_redirect?locale=en&ver=13.1&topic=sw+manuals&sub=sim.pdf
http://www.xilinx.com/cgi-bin/SW_Docs_Redirect/sw_docs_redirect?locale=en&ver=13.1&topic=sw+manuals&sub=xst.pdf
http://www.xilinx.com/cgi-bin/SW_Docs_Redirect/sw_docs_redirect?locale=en&ver=13.1&topic=sw+manuals&sub=xst_v6s6.pdf


148 www.xilinx.com ISE In-Depth Tutorial
UG695 (v13.1) March 1, 2011

Appendix A: Additional Resources

http://www.xilinx.com

