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2. Select Create templates for a new peripheral. Before continuing through the wizard, 
read through the text on this page.

Note: Each CIP wizard screen is full of useful information. You can also click More Info to view 
the related XPS help topic.

3. On the Repository or Project page, specify where to store the custom peripheral files. 

For this example, you will use this peripheral for a single embedded project. 

4. Select To an XPS project.

Because you launched the CIP wizard from within XPS, the directory location is 
automatically filled in.

Note: If the custom pcore will be used for multiple embedded projects, you can save the file in 
an EDK repository.

5. Use the Name and Version page to indicate the name and version of your peripheral. 
For this example design, use the name blink.

A version number is supplied automatically. You can also add a description of your 
project.

Figure X-Ref Target - Figure 6-2

Figure 6-2: Name and Version Page
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6. On the Bus Interface page, select the interconnection or bus type that connects your 
peripheral to your embedded design. For this example, select AXI4-Lite.

Note: You can access related data sheets from the Bus Interface page.
Figure X-Ref Target - Figure 6-3

Figure 6-3: Bus Interface Page
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7. On the IPIF (IP Interface) Services page, indicate the IPIF services for your peripheral.

The CIP wizard automatically creates the following:

- Slave connections to the AXI device

- Necessary bus protocol logic

- Signal sets used to attach your custom HDL code 

In addition to this base set of capability, you can add optional services. 

Click More Info. You can read details on each of these services to help you determine 
whether the features are necessary for your IP.

Because User Logic Software Register was selected in the IPIF Services page, the User 
Software Accessible Registers page opens.

Figure X-Ref Target - Figure 6-4

Figure 6-4: IP Interface Services Page

http://www.xilinx.com
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8. Leave the default value of 1 selected.
X-Ref Target - Figure 6-5

Figure 6-5: Software Accessible Registers
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9. On the IP Interconnect (IPIC) page, review the set of IPIC signals that the CIP wizard 
offers for your custom peripheral. If you don’t understand what these signals do, 
review the appropriate specification. The signals selected should be adequate to 
connect most custom peripherals.

X-Ref Target - Figure 6-6

Figure 6-6: IP Interconnect Page

http://www.xilinx.com
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On the Peripheral Simulation Support page, you can elect to have the CIP generate a BFM 
simulation platform for your project.

Generating BFM 
simulation platform

A BFM simulation requires a license for the AXI BFM Simulation model. For more 
information about using AXI BFMs for embedded designs with XPS, refer to refer to 
the AXI Bus Functional Models v1.9 data sheet (DS824). A link to this document is 
provided in Appendix A, “Additional Resources.” AXI BFM simulation also requires a 
supported simulator: ISim, ModelSim-SE/PE, Questa Simulator, or IES.

If you think you might want to run a BFM simulation on this IP example, generate the 
BFM platform now.

Note: AXI BFM simulation must be licensed. An AXI BFM license is not included with the  
Design Suite installation. You can purchase the license through the Xilinx Sales Channel, then 
obtain it at http://www.xilinx.com/getlicense.

Figure X-Ref Target - Figure 6-7

Figure 6-7: Peripheral Simulation Support Page
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The CIP wizard creates two HDL files that implement your pcore framework:

- The blink.vhd file - the file that contains the AXI interface logic. Assuming your 
peripheral contains ports to the outside world, you must modify this file to add 
the appropriate port names. This file is well documented and tells you exactly 
where to add the port information.
If you are a Verilog designer, don’t panic, but realize that you must write the port 
names using HDL syntax. For this example, you can find the source code in an 
upcoming Test Drive and use that source as a template for future pcore creation.

- The user_logic.vhd file - the template file where you add the custom Register 
Transfer Level (RTL) that defines your peripheral. Although you can create 
additional source files, the simple design example you are using requires only the 
user_logic.vhd file.

The Peripheral Implementation Support page lists three options for creating optional 
files for hardware and software implementation.

Verilog support The CIP wizard can create the user_logic template in Verilog instead of VHDL. To 
create the template in Verilog, select the Generate stub ‘user_logic’ template in 
Verilog instead of VHDL check box.

Figure X-Ref Target - Figure 6-8

Figure 6-8: Peripheral Implementation Support Page
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If you intend to implement your pcore design to completion (for timing analysis or 
timing simulation), click the Generate  and XST project files to help you implement 
the peripheral using XST flow check box. The CIP wizard creates the necessary 
project files for the  tools. However, if your peripheral is low-speed or very simple, this 
step is not necessary.

If your peripheral requires more complex software drivers, click the Generate 
template driver files to help you implement software interface check box. The CIP 
wizard creates the necessary driver structure and some prototype drivers based on the 
services selected.

For this example design, leave all three boxes unchecked. The final screen displays a 
summary of the CIP wizard output, including the files created and their locations.

10. Review this information and click Finish. You can observe the file creation status in the 
Console window.

Figure X-Ref Target - Figure 6-9

Figure 6-9: Create and Import Peripheral Wizard Summary Page
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What Just Happened?

Important summary 
information

Precisely what did the CIP wizard do? Let’s stop for a moment and examine some concepts 
and the resulting output.

EDK uses AXI slave and burst peripherals to implement common functionality among 
various processor peripherals. The AXI slave and burst peripherals can act as bus masters 
or bus slaves.

In the Bus Interface and IPIF Services Panel, the CIP wizard asked you to define the target 
bus and what services the IP needs. The purpose was to determine the AXI slave and burst 
peripheral elements your IP requires.

AXI slave and burst 
peripherals

The AXI slave and burst peripherals are verified, optimized, and highly parameterizable 
interfaces. They also give you a set of simplified bus protocols. Your custom RTL interfaces 
to the IPIC signals, which are much easier to work with when compared to directly 
operating on the AXI or FSL protocols. Using the AXI slave and burst peripherals with 
parameterization that suits your needs greatly reduces your design and test effort.

Figure 6-6, page 52 illustrates the relationship between the bus, a simple AXI slave 
peripheral, IPIC, and your user logic.

Figure 6-10 shows the directory structure and the key files that the CIP wizard created. 
These file reside in the /pcores subdirectory of your project directory.

Information about the files generated by the CIP wizard:

• The wizard created two HDL template files: blink.vhd and user_logic.vhd. These 
files are located in the hdl/vhdl folder.

• The user_logic file connects to the AXI device using the AXI slave core configured 
in blink.vhd. 

- The user_logic.vhd file is equivalent to the “Custom Functionality” block.

- The blink.vhd file is equivalent to the “AXI slave” block. 

• Your custom logic interfaces using the IPIC signals.

To complete your design, you must add your proprietary logic to the two files.

Figure X-Ref Target - Figure 6-10

Figure 6-10: Directory Structure Generated by the CIP Wizard
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Example Design Description
You can use the CIP wizard to create a fully functional peripheral, assuming that reading 
and writing registers provides adequate functionality. You can choose to create a simple 
peripheral this way. However, having an actual, functioning example that you can modify 
is much more valuable, so now you’ll define a simple AXI peripheral.

You’ll open and modify the source code files for this peripheral in the next Test Drive. 
These files are located in the /pcores directory on your system.

The custom peripheral blinks the four LEDs on the evaluation board.

Modifying the Template Files
In this section, you’ll modify the template files, review the files, and then add the pcore to 
your project.

Take a Test Drive! Modifying the CIP Wizard Template Files

In the next Test Drive, you will modify the code generated by the CIP wizard to implement 
the new blink peripheral.

The peripheral is very simple. A single control register is used to enable or disable a 
counter. This counter divides down the bus clock and blinks the LEDs in a binary pattern.

1. In XPS, select File > Open.

2. Navigate to the pcores\blink_v1_00_a\hdl\vhdl directory and locate the 
blink.vhd file and the user_logic.vhd file.

Note: You might have to change the Files of type drop-down list to view and open these files.

3. Open the blink.vhd file. 

In the next two steps, you’ll add the external port names in two places in this file:

- The top level entity port declaration (step 4)

- The port map for the instantiation of the user_logic (step 5)

4. Scroll down to approximately line 140. In the code segment shown here, the user port 
LEDs are displayed in the appropriate location. Add the LEDs port declaration for the 
top-level entity in your file as shown here.

Figure X-Ref Target - Figure 6-11

Figure 6-11: Add User Ports

http://www.xilinx.com
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5. Scroll down to approximately line 304. In the code segment shown here, the user port 
LEDs are displayed in the appropriate location. Add the LEDs port declaration into the 
user_logic port mapping in your file as shown here.

6. Save and close the file.

Where user information is required in the two template files (<ip core name>.vhd 
and user_logic.vhd), comments within the file indicate the type and placement of 
required information. 

In most cases, adding user ports to the top-level entity and then mapping these ports 
in the user_logic instantiation are the only changes required for <ip core 
name>.vhd.

7. Open and examine the user_logic.vhd file.

8. Scroll down to approximately line 100. In the code segment shown here, the user port 
LEDs are displayed in the appropriate location. Add the LEDs port declaration.

9. Scroll down to approximately line 133, and add this signal declaration.

Figure X-Ref Target - Figure 6-12

Figure 6-12: Add Port Mapping

X-Ref Target - Figure 6-13

Figure 6-13: Adding the LEDs Port Declaration

X-Ref Target - Figure 6-14

Figure 6-14: Adding the Signal Declaration

http://www.xilinx.com
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10. Scroll down to approximately line 214 and add the following code, beginning with 
-- Create counter. This code implements the counter logic, and connects the 
register bit to control counter operation.

Reviewing the File Contents
Assuming you are familiar with VHDL, the code that makes up blink is easy to 
understand.

The user_logic.vhd file is similar to the top-level blink.vhd file, in that the template 
contains many comments and instructs you where to add custom RTL. If you have never 
used the CIP wizard before, take a few minutes to study the comments, the list of interface 
signals, and locations where you are instructed to add your RTL.

It is essential that you do not modify the auto-generated generics and ports. Add your 
custom generics and ports only where instructed. 

At approximately line 100, notice that the user port LEDs (3 downto 0) were added. This 
output vector drives the four LEDs on the evaluation board. Anytime you add signals 
specific to your design, you must add these ports in this location. You also need to add 
these ports in the top-level file and map them through to user_logic.

Most of the code after the architecture declaration is custom code.

After declaring the internal signal count, the VHDL code that blinks the LEDs starts at line 
212.

The CIP wizard created a single user register that is connected to the counter and used to 
control the counter. Writing a one to the least significant bit will enable the counter, and 
writing a zero will stop the counter.

X-Ref Target - Figure 6-15

Figure 6-15: Adding the Counter Logic

http://www.xilinx.com


60 www.xilinx.com EDK Concepts, Tools, and Techniques
UG683 (v14.5) March 20, 2013

Chapter 6: Creating Your Own Intellectual Property

All the code described here is simple and can be modified if you want to experiment later. 
However, the interface signals in lines 208-210 are required to have very explicit behavior. 
Incorrect logic driving these signals will cause the custom pcore to interfere with proper 
bus operation, and could result in unexpected behavior during debug.

IP2Bus_Data is read by the processor during a read operation. For this simple peripheral, 
the data last written to the peripheral control register can also be read back.

The final signal, IP2Bus_WrAck, is also critical. IP2Bus_WrAck is a write acknowledge 
that must be returned by the custom logic. IP2Bus_WrAck must be driven high only for a 
single cycle, but can be delayed if your custom logic needs to add wait states to the 
response. For this example, no wait states are necessary. Connecting IP2Bus_WrAck 
directly to slv_write_ack provides a simple, zero wait state response. The logic for the 
read acknowledge signal is identical. The peripheral can add wait states if necessary.

The IP2Bus_Error is driven with a constant logic zero, implying that no error condition is 
returned. If your custom peripheral could potentially time out based on having to wait for 
other external logic, you can connect logic to drive IP2Bus_Error to terminate the bus 
transfer.

Take a Test Drive! Adding the Pcore to Your Project

To add the blink pcore to your project, you’ll first update the MPD file and add the pcore. 
Then, you’ll export the design and generate a new bitstream and test the pcore in 
hardware.

Adding the Pcore to Your Project

When you modified blink.vhd and user_logic.vhd, you added new ports to the 
template design. Any time you modify the design files in a manner that modifies the ports 
or parameters, the MPD file must be updated to reflect these changes.

1. Open the MPD file for the blink pcore from the pcores\blink_v1_00_a\data 
directory.

2. Under the comment ##Ports, add this line:

PORT LEDs = "", DIR = O, VEC = [3:0]

3. Save the file.

4. In XPS, select Project > Rescan User Repositories to force XPS to recognize the 
changes made to the blink pcore. 

Note: Xilinx recommends that you rescan the IP repositories any time you make a change to a 
custom peripheral.

Your custom pcore is now ready to add to the embedded design. 

For more information about PSF files, refer to the Platform Specification Format Reference 
Manual. A link to this document is available in Appendix A, “Additional Resources.”

You can see your custom peripheral listed in the IP Catalog under Project Local 
PCores/USER.

Note: If the IP Catalog isn’t visible, select View > Tabs > IP Catalog.

Before adding blink to your design, you must make one change to the existing design. 
The four LEDs on the evaluation board are currently connected to GPIO outputs. Now 
that blink is driving these LEDs, the LEDs_8Bit pcore must be removed from the 
design.

http://www.xilinx.com
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5. In the System Assembly View, right-click LEDs_8Bits and select Delete Instance. 
The Delete IP Instance dialog box appears: 

6. Accept the default setting. You’ll add the external ports back into the design manually.

7. Locate the blink pcore in the IP Catalog, right-click the pcore, and select Add IP.

The XPS Core Config dialog box opens automatically.

8. Accept all defaults and click OK to close the dialog box. 

The Instantiate and Connect IP window opens.

9. Accept the defaults and click OK.

XPS adds the IP to the System Assembly View. You can see it in the Bus Interfaces tab. 

The blink core is now added to the embedded system. However, you must make the 
external connections between blink and the LEDs on the evaluation board.

10. Click the Ports tab, expand blink_0, right-click LEDs, and select Make External.

A default name of blink_0_LEDs_pin was assigned as the External Ports name.

To change the assigned net and pin names, click in the Connected Port column, 
respectively. Alternatively, you can manually edit the MHS file. For now, don’t change 
the assigned names.

Figure X-Ref Target - Figure 6-16

Figure 6-16: Delete IP Instance Dialog Box

Figure X-Ref Target - Figure 6-17

Figure 6-17: Connecting Your New IP in the Bus Interfaces Tab
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11. Click the Addresses tab and change the address range for blink_0 to 0x7C600000 
- 0x7C60FFFF.

If it seems strange for a simple peripheral to be assigned a 64Kbyte address space, 
don’t worry. A wider address space requires decoding of fewer address lines. In an 
FPGA, a decoder with many inputs is implemented as a cascade of lookup tables.

The deeper the cascade, the slower the operating frequency. By assigning wide 
peripheral address ranges, the resulting FPGA implementation runs faster. 

The final step is to update the UCF constraints file to assign the LED outputs to the 
proper FPGA pins.

12. Click the Project tab and double-click the system.ucf file to open it in the XPS main 
window.

13. Look for LEDs_8Bits_TRI_O. These pin assignments were left in the UCF even 
though you earlier deleted the GPIO pcore. It is important to note that removing a 
pcore does not automatically trigger an update to the UCF file.

14. Replace LEDs_8Bits_TRI_O with blink_0_LEDs_pin in all four locations and save 
the UCF file.

Congratulations, you have created and added a custom pcore!

15. Close XPS.

Exporting the Design and Generating a New Bitstream

The next steps are to export the hardware design and generate a new bitstream and then 
test this new pcore in hardware.

1. Go back to the  tools and re-run the Generate Top Level HDL process as you did in 
“Take a Test Drive! Generating the Bitstream,” page 27.

It is necessary to rerun the Generate Top Level HDL process because when the blink 
peripheral was added, four of the top level port names were changed.

2. In the  design suite, right-click the Export Hardware Design to SDK with Bitstream 
process and select Process Properties.

3. Click the Launch SDK after Export check box to check it.

4. Run the Export Hardware Design to SDK with Bitstream process.

5. When SDK launches, create a new workspace. The new hardware platform is 
automatically imported.

SDK opens to the C/C++ Perspective with a table showing all the IP in your design. 
Confirm that blink_0 is listed in the Address Map section of the system.xml file.

6. Create a new Hello World software project and BSP by selecting File > New > 
Application Project.

7. Download the bitstream to the board by selecting Xilinx Tools > Program FPGA.

8. Run the Hello World project to confirm that the new hardware design runs correctly.

9. Select Xilinx Tools > XMD Console to open an XMD console.

We will verify the correct behavior of the blink IP by directly writing to and reading the 
control register.

http://www.xilinx.com
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10. At the XMD prompt, type the following:

a. mb. XMD connects to the MicroBlaze processor.

b. stop. The processor stops so that you can read and write to the registers.

c. mwr 0x7c600000 0x1. The LEDs on the board begin to blink.

d. mrd 0x7c600000. Confirm that you read back the value 0x00000001.

e. mwr 0x7c600000 0x0. The LEDs stop blinking.

What Just Happened?

You used the CIP wizard to create custom IP. While there are many steps required to 
complete the task, you should now be familiar enough with the steps that you should be 
able to use the CIP wizard efficiently in the future.

For more information about XMD commands, refer to the “Xilinx Microprocessor 
Debugger” chapter of the Embedded System Tools Reference Guide (UG111). A link to this 
document is available in Appendix A, “Additional Resources.”

http://www.xilinx.com
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Project Navigator Overview
Note: The test drives in this chapter are based on the 14.1 version of ISE® Design Suite Project 
Navigator. Use with later versions of the tools has not been tested and therefore might behave 
differently than described.

Project Navigator organizes your design files and runs processes to move the design from 
design entry through implementation to programming the targeted Xilinx device. Project 
Navigator is the high-level manager for your Xilinx® FPGA and CPLD designs, which 
allows you to do the following: 

• Add and create design source files, which appear in the Sources window

• Modify your source files in the Workspace

• Run processes on your source files in the Processes window

• View output from the processes in the Transcript window

Note: Optionally, you can run processes from a script you create or from a command line prompt. 
However, it is recommended that you first become familiar with the basic use of the Xilinx Integrated 
Software Environment (ISE®) tools and with project management, as described in the following 
sections.

Take a Test Drive! Creating a New Embedded Project

For this test drive, you will start the Project Navigator software and create a project with an 
embedded processor system as the top level.

1. Start the ISE Project Navigator software.

2. Select File > New Project.

http://www.xilinx.com
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3. In the New Project wizard, use the information in the table below to make your 
selections in the wizard screens.

4. When you click Finish, the New Project wizard closes and a blank KC705 project 
opens.

Next you must add an embedded project using the New Source wizard.

5. Select Project > New Source.

6. In the New Source wizard, use the information in the table below to make your 
selections in the wizard screens.

7. Click Finish to create the embedded source.

A dialog box opens, asking if you want to create a base system using the BSB wizard. 

8. Click Yes.

The first window of the Base System Builder asks you to decide whether to create an 
AXI-based or PLB-based system.

9. Select AXI System and click OK.

Wizard Screen System Property Setting or Command to Use

Create New Project Name Choose a name for your project.

Location Select a location in which to save your 
project.

Working Directory Select a working directory for your project.

This defaults to the same location you 
selected in the previous field.

Description Type a description for your project 
(optional).

Top-level source type Keep the default setting, HDL.

Project Settings Evaluation 
Development Board

Select Kintex™-7 KC705 Evaluation 
Platform.

All the other fields are populated for you 
based on your board choice. Keep these 
settings.

Wizard Screen System Property Setting or Command to Use

Select Source Type File name Name the source file. For example, system.

Caution! Do not use spaces in the file 
name or path.

Location Select a location in which to save your source. 
By default, your project directory is selected.

Add to Project Leave this option selected.

Summary Review the source summary details.

http://www.xilinx.com
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10. In the Base System Builder wizard, create a project using the settings in the following 
table. If no setting or command is indicated in the table, accept the default values.

11. To generate your design, click Finish.

Read and then dismiss any dialog boxes that open after you exit the BSB Wizard. 

Generating the Netlist

Select Hardware > Generate Netlist.This action invokes the platform building tool, 
Platgen, which does the following:

• Reads the design platform configuration MHS file and runs all necessary design rule 
checks to validate the correctness of the design.

• Synthesizes the design using Xilinx Synthesis Technology (XST).

• Produces netlist files (with an .ngc extension) for each peripheral, as well as the 
overall embedded system.

• Generates Hardware Description Language (HDL) wrapper files for each peripheral 
and the overall system. To see the created HDL files, look in the 
<project_name>\system\hdl directory.

More information about Platgen is provided in the “Platform Generator (Platgen)” chapter 
of the Embedded System Tools Reference Manual. A link to this document is available in 
Appendix A, “Additional Resources.”

You can control netlist generation using Project Navigator. In the sections ahead, we will be 
doing the actual netlist generation from within the  tools interface.

Wizard Screens System Property Setting or Command to Use

Board and System 
Selection

Board Use the default option to create a system 
for the Kintex-7 KC705 Platform.

Note: This is pre-populated because you 
selected this board in Project Navigator.

Board Configuration This information is pre-populated based 
on your board selection.

Note: If you had selected to create a 
system for a custom board, these fields 
would be editable.

Select a System Single MicroBlaze Processor System

Optimization Strategy Area

Processor, Cache, 
and Peripheral 
Configuration

Processor Frequency 100 MHz (default)

Select a Processor microblaze_0

Enable Floating Point 
Unit

Do not enable this setting.

Local Memory Size 64 KB

Instruction Cache Size 8 KB

Data Cache Size 8 KB

Select and Configure 
Peripherals

Add the axi_timer peripheral and 
select the Use Interrupt check box.
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Take a Test Drive! Generating the Bitstream

Now that you’ve described your Hardware Platform in XPS, you’ll use Project Navigator 
to implement the design and generate the bitstream.

Implementing the 
design using Project 
Navigator

Compiled C code is not part of this bitstream. It is added later in SDK.

1. Close XPS.

Generating a 
bitstream and 
creating a UCF file

You’re about to run the design through to the point at which a bitstream is generated. 
Before you can do that, you need to add some information so that the  Place and Route 
(PAR) tool has information about your design, such as the pinout.

A Project Navigator project has one top-level module that is the root of the design 
hierarchy for the purpose of implementation. When you create a new project, the 
highest level module is automatically assigned as the top module.

An XMP file cannot be a top-level module. If an XMP file is the only source in your 
project, then you must generate a VHDL or Verilog wrapper file.

Generating a top HDL 
source

2. In Project Navigator, make sure your <project>.xmp file is selected in the Source 
pane.

3. Right-click the .xmp file and select Create Top HDL Source to generate the wrapper 
file for the <project>.xmp file. This is now the top module for your project.

4. With the system_top file selected, double-click Generate Programming File in the 
Processes pane to create your bitstream. It takes a few minutes and concludes with the 
message:

Programming File” completed successfully

X-Ref Target - Figure 7-1

Figure 7-1: Viewing the Top HDL Wrapper File
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Generated bitstream 
files

The generated bitstream file is located in the \implementation folder of your project and 
is called system.bit. There is another file generated called system_bd.bmm, which SDK 
uses for loading memory onto your target board.

It is not necessary to add the constraint file (.ucf) generated by XPS to your project. Project 
Navigator automatically locates and uses the constraints during implementation.

Exporting Your Hardware Platform
You created your project in Project Navigator and added an embedded processor source, 
then designed your hardware platform in XPS using the Base System Builder, and finally 
generated a bitstream for the FPGA. Now, you will export your hardware platform 
description to the Software Development Kit (SDK).

The exported XML file has the information SDK requires for you to do software 
development and debug work on the hardware platform that you designed.

Take a Test Drive! Exporting Your Hardware Platform to 
SDK

You can export your hardware platform from XPS or from Project Navigator. In this 
tutorial, you’ll use Project Navigator to export your hardware platform, but you’ll modify 
the process properties so that SDK doesn’t open. You’ll work with SDK in the next chapter.

1. In Project Navigator, expand system_top and select your system.xmp file.

2. In the Processes pane, right-click Export Hardware Design to SDK with Bitstream 
and select Process Properties.

3. Uncheck the Launch SDK after Export option and click OK.

4. Double-click Export Hardware Design to SDK with Bitstream.

What Just Happened?

Project Navigator exported your hardware design to SDK. It is important to understand 
the export operation, especially if you are managing multiple hardware versions.

When you export your hardware design to SDK, a utility creates a number of files used by 
SDK. In addition to the XML file, documentation on the software drivers and hardware IP 
is included so you can access necessary information from within SDK.

In the \system\SDK\SDK_Export\hw directory, a number of HTML files are created in 
addition to the system.xml file. Opening the system.html file shows a hyperlink-
enabled block diagram with all of the details of your embedded hardware platform.

Notice that the Launch SDK after Export option was selected by default. When this is 
selected, SDK launches after Project Navigator exports the design. When SDK launches 
this way, it automatically imports the hardware platform for your design.
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Chapter 8

Creating a New Project Using the 
Vivado Design Suite

Vivado Design Suite Overview
The Vivado™ Integrated Design Environment (IDE) provides an easy-to-use design flow 
that can be run using a graphical user interface (GUI) or using Tool Command Language 
(Tcl) commands and scripts.

The design flow includes the following high-level steps:

1. RTL synthesis

2. Netlist linking and constraint application

3. Placement, packing, and optimization

4. Routing and optimization

5. Static timing analysis

6. Bitstream generation

7. Exporting Hardware details to SDK
X-Ref Target - Figure 8-1

Figure 8-1: Basic Vivado Embedded Design Flow
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In this chapter, you will create a project with an embedded processor system using the 
Vivado Design Suite.

You will use Base System Builder (BSB) wizard to create a MicroBlaze™ processor based 
default system for the Kintex™-7-based KC705 Board.

Note: For information about the BSB wizard, refer to Chapter 2.

The following Test Drive walks you through starting your new project in the Vivado 
Design Suite and using the New Project wizard to create your project.

Take a Test Drive! Creating a New Embedded Project

For this test drive, you will start the Vivado IDE and create a project with an embedded 
processor system as the top level.

1. Start the Vivado IDE.

2. In the Welcome window, select Create New Project.

3. Use the information in the table below to make your selections in the wizard screens.

When you click Finish, the New Project Wizard closes and a blank KC705 Vivado 
project opens.

4. Verify the FPGA part, target language, and simulator settings by clicking Project 
Settings in the Flow Navigator panel.

5. To add an EDK project, click Add Sources in the Flow Navigator panel.
Note: You can also add a source using the shortcut Alt + A.

The Add Sources wizard opens.
6. Click Add or Create Embedded Sources and click Next.
7. Click Create Sub-Design.
8. In the dialog box that opens, type system as a name for the module and click OK.
9. Click Finish.

Wizard Screen System Property Setting or Command to Use

Project Name
Project name

Choose a name and location 
for your project.

Create Project Subdirectory Leave this option checked.

Project Type Specify the type of project to 
create.

RTL Project

Add Sources This is optional; no changes needed for this example.

Add Existing IP Optional; no changes needed.

Add Constraints Optional; no changes needed.

Default Part

Specify Select Boards.

Board list
Select Kintex-7 KC705 
Evaluation Platform.

New Project 
Summary

Review the project settings.
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The Vivado design tool creates your embedded design source project. It recognizes 
that you have an embedded processor system and starts Xilinx® Platform Studio 
(XPS).

Next, you'll use the BSB wizard to create a Base System in XPS.

1. A dialog box opens with the following message:

This project appears to be a blank project. Do you want to create 
a Base system using the BSB wizard?

2.  Click Yes.

The first window of the BSB asks you to select an Interconnect Type. By default, an AXI 
System is selected.

Note: PLB system is disabled in the Wizard.

3. Click OK.

4. In the Base System Builder wizard, create a project using the settings described in the 
following table. If no setting or command is indicated in the table, accept the default 
values.

5. To generate your design, click Finish.

Wizard Screens System Property Setting or Command to Use

Board and System 
Selection

Board Use the default option to create a system for the 
Kintex-7 KC705 Evaluation Platform.

Note: This is pre-populated because you selected 
this board in the Vivado tool.

Board 
Configuration

This information is pre-populated based on your 
board selection.

Note: If you had selected to create a system for a 
custom board, these fields would be editable.

Select a System Single MicroBlaze Processor System

Optimization 
Strategy

Area

Processor, Cache, 
and Peripheral 
Configuration

Processor 
Frequency

100 MHz (default)

Select a 
Processor

microblaze_0

Enable Floating 
Point Unit

Do not enable this setting.

Local Memory 
Size

64 KB

Instruction 
Cache Size

64 KB

Data Cache Size 64 KB

Select and 
Configure 
Peripherals

Add the axi_timer peripheral and select the 
Use Interrupt check box.
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Read and then dismiss any dialog boxes that open after you exit the BSB Wizard.

Note: For more information about XPS, refer to Chapter 3, “Using Xilinx Platform Studio.”

6. Close XPS.

Next, you’ll run through the design to the point at which a bitstream is generated.

First, you need to provide some information about your design, such as the pinout, to the 
Vivado design tool.

A project in the Vivado design tool has one top-level module that is the root of the design 
hierarchy for the purpose of implementation. When you create a new project, the highest 
level module is automatically assigned as the top module.

An XMP file cannot be a top-level module. If an XMP file is the only source in your project, 
then you must generate a VHDL or Verilog wrapper file.

1. In the Vivado IDE, make sure your system.xmp file is selected in the Source pane.

2. Right-click the system.xmp file and select Create Top HDL Source to generate the 
wrapper file for the system.xmp file. This is now the top module for your project.

3. In the Flow Navigator pane, expand Program and Debug and then click Generate 
Bitstream.

If a critical warning appears, you can safely ignore it.

X-Ref Target - Figure 8-2

Figure 8-2: Viewing the New Verilog Wrapper File
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Bitstream generation takes some time and concludes with below message window:

4. Select View Reports and click OK.

It shows reports related to Synthesis, Place and Route, and Bitstream.

Generated bitstream 
files

The generated bitstream file is located in the <Project_1>\<Project_1.runs>\impl_1 
folder of your project and is called system_stub.bit. There is another file generated 
called system_bd.bmm, which SDK uses for loading memory onto your target board.

It is not necessary to add the Xilinx Design Constraint file (.xdc) file that was generated by 
XPS to your project. The Vivado design tool automatically locates and uses the constraints 
during implementation.

Exporting Your Hardware Platform
You created your project in the Vivado design tool and added an embedded processor 
source, then designed your hardware platform in XPS using the Base System Builder, and 
finally generated a bitstream for the FPGA. Now, you will export your hardware platform 
description to the Software Development Kit (SDK).

The exported XML file has the information that SDK requires for you to do software 
development and debug work on the hardware platform that you designed.

Take a Test Drive! Exporting Your Hardware Platform to 
SDK 

You can export your hardware platform from XPS or from the Vivado design environment. 
In this tutorial, you'll use the Vivado tool to export your hardware platform.

1. In the Vivado IDE, select File > Export > Export Hardware.

2. In the Export Hardware dialog box that opens, select the Include Bitstream and Export 
Hardware options.

3. Click OK.

X-Ref Target - Figure 8-3

Figure 8-3: Bitstream Generation Completed Dialog Box
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What Just Happened?

The Vivado design tool exported your hardware design to SDK. It is important to 
understand the export operation, especially if you are managing multiple hardware 
versions.

When you export your hardware design to SDK, a utility creates a number of files used by 
SDK. In addition to the XML file, documentation on the software drivers and hardware IP 
is included so you can access necessary information from within SDK.

What's Next?
Now you can start developing the software for your project using SDK. Go to Chapter 5, 
“Software Development Kit,” which explains embedded software design fundamentals.
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Appendix A
Additional Resources
Xilinx Resources

• Xilinx® Device User Guides:
http://www.xilinx.com/support/documentation/user_guides.htm 

• Glossary of Terms: http://www.xilinx.com/company/terms.htm

• ISE Design Suite 14: Release Notes, Installation, and Licensing Guide:
http://www.xilinx.com/support/documentation/sw_manuals/xilinx14_5/irn.pdf

• Product Support and Documentation: http://www.xilinx.com/support

EDK Documentation
You can access the entire documentation set online at: 
http://www.xilinx.com/support/documentation/dt_edk_edk14-5.htm

Individual documents are linked below.

• EDK Profiling Guide (UG448):
http://www.xilinx.com/support/documentation/xilinx14_5/edk_prof.pdf

• Embedded System Tools Reference Manual (UG111):
http://www.xilinx.com/support/documentation/xilinx14_5/est_rm.pdf

• MicroBlaze™ Processor User Guide (UG081): 
http://www.xilinx.com/support/documentation/sw_manuals/xilinx14_5/
mb_ref_guide.pdf

• Platform Specification Format Reference Manual (UG642):
http://www.xilinx.com/support/documentation/xilinx14_5/psf_rm.pdf

• AXI Bus Functional Models v1.9 Data Sheet (DS824):
http://www.xilinx.com/support/documentation/ip_documentation/cdn_axi_bfm/
v1_9/ds824_axi_bfm.pdf

EDK Additional Resources
• EDK Tutorials website:

http://www.xilinx.com/support/documentation/dt_edk_edk14-5_tutorials.htm

• Platform Studio and EDK website:
http://www.xilinx.com/ise/embedded_design_prod/platform_studio.htm

• XPS/EDK Supported IP website:
http://www.xilinx.com/ise/embedded/edk_ip.htm

http://www.xilinx.com
http://www.xilinx.com/support/documentation/ip_documentation/cdn_axi_bfm/v1_9/ds824_axi_bfm.pdf
http://www.xilinx.com/cgi-bin/docs/ndoc?l=en;t=user+guide
http://www.xilinx.com/cgi-bin/docs/ndoc?l=en;t=glossary
http://www.xilinx.com/cgi-bin/docs/rdoc?v=14.5;t=release+notes

http://www.xilinx.com/cgi-bin/docs/ndoc?l=en;t=support
http://www.xilinx.com/support/documentation/dt_edk_edk14-5.htm
http://www.xilinx.com/cgi-bin/docs/rdoc?l=en;v=14.5;d=edk_prof.pdf
http://www.xilinx.com/cgi-bin/docs/rdoc?l=en;v=14.5;d=est_rm.pdf
http://www.xilinx.com/cgi-bin/docs/rdoc?l=en;t=user+guide;d=mb_ref_guide.pdf
http://www.xilinx.com/cgi-bin/docs/rdoc?l=en;v=14.5;d=psf_rm.pdf
http://www.xilinx.com/cgi-bin/docs/rdoc?l=en;v=14.5;t=edk+tutorials
http://www.xilinx.com/ise/embedded_design_prod/platform_studio.htm
http://www.xilinx.com/ise/embedded/edk_ip.htm


78 www.xilinx.com EDK Concepts, Tools, and Techniques
UG683 (v14.5) March 20, 2013

Appendix A: Additional Resources

http://www.xilinx.com

