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Profiling and Performance Tuning 

Introduction 

This lab guides you through the process of profiling an application and analyzing the output. The 
application is then accelerated in hardware and profiled again to analyze the performance improvement.  

Objectives  

After completing this lab, you will be able to: 
• Setup the board support package (BSP) for profiling an application 

• Set the necessary compiler directive on an application to enable profiling 
• Setup the profiling parameters 

• Profile an application and analyze the output 

Procedure  

This lab is separated into steps that consist of general overview statements that provide information on 
the detailed instructions that follow. Follow these detailed instructions to progress through the lab. 

Design Description 

In this lab, you will design an embedded system consists of ARM Cortex-A9 processor SoC and two 
instances of the provided FIR filter IP.  The following diagram represents the completed design (Figure 1). 

 
Figure 1 Completed Design 
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General Flow for this Lab  

 

 

 

 

 

 

 

Create a Vivado Project Step 1 

1-1. Launch Vivado and create an empty project, called lab6, targeting the Zybo 
or ZedBoard Zynq Evaluation and Development Kit and using the VHDL 
language. 

1-1-1. Open Vivado and create a new project new project call lab6 in the c:\xup\adv_embedded\labs 
directory. 

1-1-2. Select the RTL Project option in the Project Type form, and click Next. 

1-1-3. Select Verilog as the Target Language in the Add Sources form, and click Next. 

1-1-4. Click Next two times. 

1-1-5. In the Default Part form, click on Boards and select either the Zybo or Zedboard and click Next. 

1-1-6. Click Finish to create an empty Vivado project.   

1-2. Set the project settings to include provided fir_top IP 

1-2-1. Click Project Settings in the Flow Navigator pane. 

1-2-2. Select IP in the left pane of the Project Settings form. 

1-2-3. Click on the Add Repository… button, browse to c:\xup\adv_embedded\sources\lab6\fir_ip 
and click Select. 

1-2-4. The fir_top _v1_0 IP will appear the IP in the Selected Repository window. 

1-2-5. Click OK. 
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Creating the Hardware System Using IP Integrator Step 2 

2-1. Create a block design in the Vivado project using IP Integrator to generate 
the Zynq ARM Cortex-A9 processor based hardware system. 

2-1-1. In the Flow Navigator, click Create Block Design under IP Integrator. 

2-1-2. Name the block system and click OK. 

2-1-3. Click on Add IP in the message at the top of the Diagram panel. 

2-1-4. Once the IP Catalog is open, type zy into the Search bar, and double click on ZYNQ7 
Processing System entry to add it to the design. 

2-1-5. Click Run Block Automation, and click OK to accept the default settings. 

2-1-6. Double click on the Zynq block to open the Customization window for the Zynq processing 
system.  

A block diagram of the Zynq should now be open, showing various configurable blocks of the 
Processing System. 

2-2. Configure the I/O Peripherals block to only have UART 1 support.  Deselect 
the TTC device.   

2-2-1. Click on the MIO Configuration panel to open its configuration form. 

2-2-2. Expand the IO Peripherals on the right. 

2-2-3. Uncheck ENET 0, USB 0, and SD 0, GPIO (GPIO MIO), leaving UART 1 selected. 

2-2-4. In the MIO Configuration panel, expand the Application Processing Unit and uncheck the 
Timer 0. 

2-2-5. Click OK. 

 
Figure 2 ZYNQ Processing System configured block 
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Add FIR Core to the System Step 3 

3-1. Instantiate the provided FIR core twice naming the instances as fir_left and 
fir_right. Validate the design. 

3-1-1. Click the Add IP icon  and search for fir in the catalog.  

3-1-2. Double-click on the fir_top_v1_0 to add the IP instance to the system  

3-1-3. Select the fir_top_1 instance and change its name to fir_left in its property form. 

3-1-4. Click the Add IP icon  and search for fir in the catalog.  

3-1-5. Double-click on the fir_top_v1_0 to add the IP instance to the system  

3-1-6. Select the fir_top_1 instance and change its name to fir_right in its property form. 

3-1-7. Click on Run Connection Automation, and select All Automation to select fir_left and fir_right.  

3-1-8. Click on s_axi_fir_io for both fir_left and fir_right and confirm that they will be automatically 
connected to the Zynq M_AXI_GP0 port 

 
Figure 3 Connection automation for the FIR IP blocks 

3-1-9. Click OK to connect the two blocks to the M_AXI_GP0  interface.  

The design should look similar to shown below: 
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Figure 4 The completed design 
 
It is not necessary to connect the interrupt signals of the fir blocks. 

3-1-10. Select Tools > Validate Design to run the design rule checker and to make sure that there are 
no design errors. 

Generate the Bitstream Step 4 

4-1. Create the top-level HDL of the embedded system, and generate the 
bitstream..   

4-1-1. In Vivado, select the Sources tab, expand the Design Sources, right-click the system.bd and 
select Create HDL Wrapper and click OK. 

4-1-2. Click on the Generate Bitstream in the Flow Navigator pane to synthesize and implement the 
design, and generate the bitstream. 

4-1-3. Click Yes to save the design and OK to run the necessary processes. 

4-1-4. When the bitstream generation process has completed click Cancel. 

Export the Design to the SDK Step 5 

5-1. Export the design to the SDK, create the software BSP using the 
standalone operating system and enable the profiling options.  

5-1-1. Export the hardware configuration by clicking File > Export > Export Hardware… 

5-1-2. Tick the box to Include Bitstream, and click OK  

5-1-3. Launch SDK by clicking File > Launch SDK and click OK 
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5-1-4. In SDK, select File > New > Board Support Package. 

5-1-5. Notice Standalone_bsp_0 in the Project name field and click Finish with default settings. 

A Board Support Package Settings window will appear. 

5-1-6. Select the Overview > standalone entry in the left pane, click on the drop-down arrow of the 
enable_sw_intrusive_profiling Value field and select true. 

 

Figure 5 Enable profiling in the board support package 

5-1-7. Select the Overview > drivers > cpu_cortexa9 and add –pg in addition to the –g in the 
extra_compiler_flags Value field. 

 

Figure 6 Adding profiling switch 

5-1-8. Click OK to accept the settings and create the BSP. 

Create the Application Step 6 

6-1. Create the lab6 application using the provided lab6.c, fir.c, fir.h, fir_coef.dat, 
and xfir_fir_io.h  files. 

6-1-1. Select File > New > Application Project.  

6-1-2. Enter lab6 as the project name, select the Use existing standalone_bsp_0 option, and click Next. 

6-1-3. Select Empty Application in the Available Templates pane and click Finish. 

6-1-4. In the lab6 project, right click on the src directory and select Import.  
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6-1-5. Expand the General folder and double-click on File system, and browse to the 
c:\xup\adv_embedded\sources\lab6 directory. 

6-1-6. Select fir_coef.dat, fir.c, fir.h, lab6.c, and xfir_fir_io.h, and click Finish. 

The program should compile successfully and generate the lab6.elf file. 

6-1-7. Open the lab6.c file and scroll to the main function at the bottom. Notice the following code: 

 

The function fir_software( ) function is a software implementation of the FIR function. The 
filter_hw_accel_input( ) function offloads the FIR function to the two FIR blocks that have been 
implemented in the PL. 

Run the Application and Profile Step 7 

7-1. Place the board into the JTAG boot up mode. Program the PL section and 
run the application using the user defined SW_PROFILE symbol.  

7-1-1. Place the board in the JTAG boot up mode. 

7-1-2. Power ON the board. 

7-1-3. Select Xilinx Tools > Program FPGA and click on Program. 

7-1-4. Right click on the lab6 directory, and select C/C++ Build Settings. 

7-1-5. Under the ARM gcc compiler group, select the Symbols sub-group, click on the  button to 
open the value entry form, enter SW_PROFILE, and click OK. 

This will allow us to profile the software loop of the FIR application. 

 

Figure 7 Add user-defined symbol 
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7-1-6. Under the ARM gcc compiler group, select the Profiling sub-group, then check the Enable 
Profiling box, and click OK. 

 

Figure 8 Compiler setting for enabling profiling 

7-1-7. From the menu bar, Select Run > Run Configurations… and double click on Xilinx C/C++ 
application to create a new configuration. 

7-1-8. Click on the newly created lab6 Debug configuration, and select the Profile Options tab.  

7-1-9. Click on the Enable Profiling check box, enter 100000 (100 kHz) in the Sampling Frequency field, 
enter 0x10000000 in the scratch memory address field, and click Apply. 

 

Figure 9 Profiling options 

7-1-10. Click the Run button to download the application and execute it. 

The program will run, and when execution has completed, a message will be displayed indicating 
that the profiling results are being saved in gmon.out file at the lab6\Debug directory. 

7-1-11. Click OK. 

7-2. Invoke gprof and analyze the results. 

7-2-1. Expand the Debug folder under the lab6 project in the Project Explorer view, and double click on 
the gmon.out entry. 



Lab Workbook  Profiling and Performance Tuning 

 

 www.xilinx.com/university ZedBoard 6-9 
 xup@xilinx.com 
 © copyright 2013 Xilinx 

 

Figure 10 Invoking gprof on gmon.out  

7-2-2. The Gmon File Viewer dialog box will appear showing lab6.elf as the corresponding binary file.  
Click OK. 

7-2-3. Click on the Sort samples per function button ( ).  

7-2-4. Click in the %Time column to sort in the descending order.  

Note that the fir_software routine is called 60 times, 23 samples were taken during the profiling, 
and on an average of 3.833 microseconds were spent per call. 

 

Figure 11 Sorting results 

7-2-5. Go back to the Run Configuration, and change the sampling frequency to 1000000 (1 MHz) and 
profile the application again. 

7-2-6. Invoke gprof, select the Sorts samples per function output, and sort the %Time column. 
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Notice that the output has better resolution and reports more functions and more samples per 
function calls. Note that the number of calls to the fir_software function has not changed but the 
number of samples taken increased, and the average time spent per call is 6.283 microseconds 
in the figure below. 

 

Figure 12 Profiled results with 1 MHz sampling frequency 

At this stage, the designer of the system would decide if the FIR function should be ported to 
hardware.   

7-3. Profile the application using the hardware FIR filter IP by removing the user 
defined SW_PROFILE symbol.  

7-3-1. Select the lab6 application, right-click, and select C/C++ Build Settings. 

7-3-2. Under the ARM gcc compiler group, select the Symbols sub-group, select SW_PROFILE, and 
delete it by clicking on the delete button. 

This will allow us to profile the hardware IP of the FIR application. 

 

Figure 13 Deleting the user-defined symbol 

7-3-3. Click Apply, and then click OK 
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7-3-4. Select Run > Run Configurations and click the Run button to profile the application again and 
click OK when profiling completes. 

7-3-5. Open  gmon.out, select the Sorts samples per function output, and sort the %Time column. 

Notice that the output now shows filter_hw_accel_input function call instead of the fir_software 
function call. Note that the number of calls to the filter function has not changed but the average 
time spent per call is 1.683 us as the filtering is done in the hardware instead of the software. 

Also notice that the amount of time spent in the filtering function reduced from about 92% to 
0.25%. 

 

Figure 14 Profiling the application with the hardware IP 

7-3-6. Close the SDK and Vivado programs by selecting File > Exit in each program. 

7-3-7. Turn OFF the power on the board. 

Conclusion  

This lab led you through enabling the software BSP and the application settings for the profiling.  You 
went through creating the hardware which included the hardware IP and was later profiled in the 
application.  You analyzed the profiled application output. 

 
 


