UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 1245

Gen_sch8 fails under Mentor B.x with "Unresolved Propagate symbol"

Description

Keywords: gen_sch8, Mentor B.x, unresolved symbol

Urgency: Standard

General Description:

While running Gen_sch8 (possibly under Fncsim8 or Timsim8) on a system with
Mentor Graphics B.x installed, you may get the following error:

/usr/lib/dld.sl: Unresolved Propagate symbol:
d_triplet_mode__14Eddm_evaluator (data) from
/usr/tools/xact/bin/hppa/gen_sch8
/usr/lib/dld.sl: Not enough space
/usr/lib/dld.sl: Unresolved Propagate symbol:
d_timing_status__14Eddm_evaluator (data) from
/usr/tools/xact/bin/hppa/gen_sch8
/usr/lib/dld.sl: Not enough space
/usr/lib/dld.sl: Unresolved Propagate symbol:
d_client_prop_lookup_fn__14Eddm_evaluator (data) from
/usr/tools/xact/bin/hppa/gen_sch8
/usr/lib/dld.sl: Not enough space
/usr/lib/dld.sl: Unresolved Propagate symbol:
d_client_notify_fn__14Eddm_evaluator (data) from
/usr/tools/xact/bin/hppa/gen_sch8
/usr/lib/dld.sl: Not enough space
/usr/lib/dld.sl: Unresolved Propagate symbol:
d_trplt_counter__14Eddm_evaluator (data) from
/usr/tools/xact/bin/hppa/gen_sch8
/usr/lib/dld.sl: Not enough space
/usr/tools/xact/com/hppa/gen_sch8[42]: 9779 Abort(coredump)

This is caused by an incompatibility between XACT 5.2.1 (written for Mentor
A.x) and Mentor B.x.

Solution

A patch is available on the Xilinx FTP site. For more information, see
Solution 997, "Using XACT 5.2.1 with Mentor Graphics' B.1/B.2 release"
AR# 1245
Date Created 08/31/2007
Last Updated 10/07/2008
Status Archive
Type General Article