UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 14698

7.1i ISE - I cannot add a UCF to a new project; the message "'my.ucf' is already in the project" is reported

Description

Keywords: UCF, associate, association, source, add, new

I cannot add or create a UCF in a project that does not contain other source files. I attempt to select "*.ucf" files by going to Selecting Project -> Add Source. However, when I select the desired UCF, an "Associate with Source" dialog box appears; there are no available sources in the dialog box, and if I select either "Cancel" or "OK", the action is closed.

Or, I attempt to select an implementation constraints file by going to Project -> New Source. Again, no source files are available with which I can associate the ".ucf" file; when the process finishes, it reports the following:

"'my.ucf' is already in the project; it cannot be added again."

Solution

In the 7.1i software, UCF files are considered to be source files and must be associated with a design source file.

You can create a UCF file by going to Project -> New Source and edit the file by going to File -> Open, but the UCF cannot be added to the project until a design source file has been added.
AR# 14698
Date Created 05/16/2002
Last Updated 12/11/2006
Status Archive
Type General Article