UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 2258

M1.3(FPGA Compiler)-Common issues/solns when re-compiling M1.3 XSI XDW libraries

Description

keywords: M1.3, XSI, XDW, vhdlan, VSS

urgency: standard

general description:

When M1.3 XSI is installed, if the version of Synopsys
is newer than v3.4b, the M1.3 XSI XDW libriaries must
be re-compiled before using them. In the Synopsys toolset,
M1.3 XDW libaries are a DesignWare library, which must
be compiled with the current version of Synopsys in use.

(If the version of Synopsys used with M1.3 is 3.4b, then
the M1.3 software just has to be installed. No
re-compilation of the XSI XDW and XSI simulation libaries
is needed.)

During recompilation of the XDW libraries with a version of
Synopsys newer than v3.4b, the user may see the following
message:

Warning: Can't read link_library file 'your_library.db' (UID-3)

and/or

messages from the OS that certain files cannot be found; The
user will see that the files under
$XILINX/synopsys/libraries/dw/lib have not been updated.






Solution

1

When the script install_dw.dc was run, if the only
message on the screen that appeared was:

Warning: Can't read link_library file 'your_library.db' (UID-3)


then the re-compilation of the M1.3 XDW libraries has been
successful. This warning, it it was the only warning received,
can be ignored.

2

In a case where the install_dw.dc script reports
that certain files couldn't be found, and/or
the files in $XILINX/synopsys/libraries/dw/lib have not been
updated, please check the following:


Make sure you are using Synopsys 3.4b or later.

Make sure that the $XILINX environment variable is
set to the top of the M1.3 software tree.

Make sure the $SYNOPSYS environment variable is
set to the top of the Synospys software tree.

Make sure that you have write permissions in the
$XILINX/synopsys/libraries/dw/lib tree.
AR# 2258
Date Created 08/31/2007
Last Updated 10/06/2008
Status Archive
Type General Article