UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 22905

8.1i CORE Generator - Closing CORE Generator produces a warning: "libgcc_s.so.1 must be installed for pthread_cancel to work"

Description

Keywords: IP, CORE, COREGen, CORE Generator, core, generate, exit, close, dump, Linux, release 4, Red Hat, enterprise, ncsim

CORE Generator issues the following message when the main GUI is closed in a normal fashion (File -> Exit) on a Linux release 4 platform:

"<prompt>: Closed project file.
libgcc_s.so.1 must be installed for pthread_cancel to work"

Additionally, CORE Generator produces a large (~100 MByte) dump file (core.12345).

This problem occurs only if CORE Generator is exited just after the generation of a new core or the re-generation of an existing core.

If an existing project is opened but no core is added or regenerated, the problem does not occur.

Solution

This problem has been seen on Red Hat Enterprise Linux WS when a different version of libgcc (from the version used by ISE) is found in the LD_LIBRARY_PATH directories. In particular, the libgcc version shipped with ncsim has been found to cause this conflict. To avoid the conflict, remove the directory with libgcc from the LD_LIBRARY_PATH. Otherwise, since the error only effects the closing of CORE Generator, it can be safely ignored. However, the core dump file should be deleted.
AR# 22905
Date Created 09/04/2007
Last Updated 03/04/2008
Status Archive
Type General Article